URLEncodedFormat ISO8859 ou UTF8

After migration from Coldfusion to Luccee,
I have a problem in the rendered value of URLEncodedFormat

Under Coldfusion I had an ISO url code (%E9 )
Under Lucee I have a UTF8 url code. (becomes : %A9 )

Files code have not been modified, just a copy.
Why this change ?
How to fix this ?

I have these code lined in the application.cfm :


<cfset setEncoding(“URL”, “iso-8859-1”)>
<cfset setEncoding(“FORM”, “iso-8859-1”)>

Thanks for help.
Pierre.

Try putting on the
template that is giving you the problem. It may be that each template is
compiled using utf-8 on lucee unless a cfprocessingdirective on that
template indicates otherwise.

See http://blog.adamcameron.me/2013/10/cfcamp-and-how-not-to-use-it.html

Aria Media Sagl
+41 (0)76 303 4477 cell
skype: ariamediaOn Thu, Sep 22, 2016 at 1:58 PM, Pierre Larde <@Pierre_Larde> wrote:

After migration from Coldfusion to Luccee,
I have a problem in the rendered value of URLEncodedFormat

Under Coldfusion I had an ISO url code (%E9 )
Under Lucee I have a UTF8 url code. (becomes : %A9 )

Files code have not been modified, just a copy.
Why this change ?
How to fix this ?

I have these code lined in the application.cfm :


<cfset setEncoding(“URL”, “iso-8859-1”)>
<cfset setEncoding(“FORM”, “iso-8859-1”)>

Thanks for help.
Pierre.


Get 10% off of the regular price for this years CFCamp in Munich, Germany
(Oct. 20th & 21st) with the Lucee discount code Lucee@cfcamp. 189€
instead of 210€. Visit https://ti.to/cfcamp/cfcamp-
2016/discount/Lucee@cfcamp

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/lucee/bbba0838-b90a-4b77-9415-3721c2c28531%40googlegroups.com
https://groups.google.com/d/msgid/lucee/bbba0838-b90a-4b77-9415-3721c2c28531%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

No, I tried it : no change.
It did work Under Coldfusion.
It seems that URLEncodedFormat always render under UTF8 with Lucee ?
(even if ISO-8859 is required)
Only that function URLEncodedFormat does that.
Rest of page is correct ISO-8859.Le jeudi 22 septembre 2016 13:58:40 UTC+2, Pierre Larde a écrit :

After migration from Coldfusion to Luccee,
I have a problem in the rendered value of URLEncodedFormat

Under Coldfusion I had an ISO url code (%E9 )
Under Lucee I have a UTF8 url code. (becomes : %A9 )

Files code have not been modified, just a copy.
Why this change ?
How to fix this ?

I have these code lined in the application.cfm :


<cfset setEncoding(“URL”, “iso-8859-1”)>
<cfset setEncoding(“FORM”, “iso-8859-1”)>

Thanks for help.
Pierre.

OK, thanks very much, it does work.
Then I understand that in Lucee URLencode is UTF-8 as default.
to get ISO, that must be added in the function.

Which is a little bit different Under Coldfusion, as it takes the default
of the page.

Pierre.Le jeudi 22 septembre 2016 13:58:40 UTC+2, Pierre Larde a écrit :

After migration from Coldfusion to Luccee,
I have a problem in the rendered value of URLEncodedFormat

Under Coldfusion I had an ISO url code (%E9 )
Under Lucee I have a UTF8 url code. (becomes : %A9 )

Files code have not been modified, just a copy.
Why this change ?
How to fix this ?

I have these code lined in the application.cfm :


<cfset setEncoding(“URL”, “iso-8859-1”)>
<cfset setEncoding(“FORM”, “iso-8859-1”)>

Thanks for help.
Pierre.

I added the iso-8859-1 in the Lucee admin server charset. (as default)
Same result

And, from the database, the field value render correctly if it is displayed
in the page (iso-8859-1)
and get an utf-8 value if it is rendered Inside the URLencodedFormat
Then this does not come from the database or the datasource.

- #p_ville#

ville=#URLEncodedFormat(p_ville)#’ is displayed in UTF-8
and

  • #p_ville# is displayed in iso-8859-1

It seems, there is a problem with the URLEncodeFormat function.
It always render in UTF-8

Thanks for any help, this is a point where I will have to go back to
Coldfusion if no solution.
Thanks to all.
Pierre.Le jeudi 22 septembre 2016 13:58:40 UTC+2, Pierre Larde a écrit :

After migration from Coldfusion to Luccee,
I have a problem in the rendered value of URLEncodedFormat

Under Coldfusion I had an ISO url code (%E9 )
Under Lucee I have a UTF8 url code. (becomes : %A9 )

Files code have not been modified, just a copy.
Why this change ?
How to fix this ?

I have these code lined in the application.cfm :


<cfset setEncoding(“URL”, “iso-8859-1”)>
<cfset setEncoding(“FORM”, “iso-8859-1”)>

Thanks for help.
Pierre.