Upgrade to 5.3.1.102 - java.lang.NullPointerException

#1

I have four instances of Lucee running for four sites.

They were all on 5.3.1.95. I upgraded each one to 5.3.1.102 a few minutes ago - except one. One would not upgrade.

I got:

java.lang.NullPointerException

I tried three times.

I restarted the instance of Lucee. Tried again, same error.

I downloaded the core file (.lco) and copied to patches. That updated the version.

Still, want to be able to use the server admin to do this, not sftp.

0 Likes

#2

There was an older (but still somewhat recent… version 5.x something) that would NPE when you tried to autoupdate. Guessing you’re experiencing that. IIRC it had to do with the specific Lucee and Java versions that it was running. You could do a “manual” upgrade where you save your lucee config file, uninstall then reinstall and copy over the relevant lucee configs to your new config file. It’s a bit more work, but It’smy default fallback for things like this. Wouldn’t hurt to get your Tomcat’s and Java’s updated anyway probably.

0 Likes

#3

My entire stack was recently updated and reinstalled (Java, Tomcat, etc) to the latest versions before installing Lucee anywhere. The Lucee versions are/were all the same. Four in total, all installed and upgraded at the same time(s). Just one of them didn’t want to upgrade. After manually installed the .lco jar, it worked. I eventually re-installed Lucee in this particular instance.

0 Likes