Upgrade 4.5 to 5 on Windows 7 DOESN'T WORK! HELP!

I am trying to upgrade from Lucee 4.5 to 5 on Windows 7. First I tried
simply replacing the lucee.jar as explained here:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

But after doing it and restarting the Lucee service, I could no longer
access my lucee apps. Instead of troubleshooting, or reverting, I decided
to install from the Windows installer. Before doing that, I did the
following:

  1. Lucee Service wouldn’t stop, so I set it to startup manually and
    restarted my machine.
  2. After restarting, I renamed my old lucee folder to lucee-old because I
    need to restore some tomcat settings.
  3. Then I ran the Windows installer, which failed to start the Lucee
    service.

Now I have a fresh C:\lucee directory, but I cannot start the service. When
I try, it stops immediately. Looking at tomcat logs, I get:

lucee-stdout.2016-09-23.log

2016-09-23 16:57:28 Commons Daemon procrun stdout initialized
Error occurred during initialization of VM
agent library failed to init: instrument

lucee-stderr.2016-09-23.log:

The specified service already exists.

Failed to install service
2016-09-23 16:53:54 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee-
inst.jar

2016-09-23 16:57:28 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee-
inst.jar

commons-daemon.2016-09-23.log

[2016-09-23 16:53:47] [info] [10472] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10472] Service Lucee name Lucee
[2016-09-23 16:53:47] [error] [10472] The specified service already exists.
[2016-09-23 16:53:47] [error] [10472] Failed installing ‘Lucee’ service
[2016-09-23 16:53:47] [error] [10472] The specified service already exists.
[2016-09-23 16:53:47] [error] [10472] Commons Daemon procrun failed with
exit value: 8 (Failed to install service)
[2016-09-23 16:53:47] [error] [10472] The specified service already exists.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10304] Updating service…
[2016-09-23 16:53:47] [info] [10304] Service ‘Lucee’ updated
[2016-09-23 16:53:47] [info] [10304] Update service finished.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun finished
[2016-09-23 16:53:54] [info] [ 7944] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:54] [info] [ 7944] Running ‘Lucee’ Service…
[2016-09-23 16:53:54] [info] [11064] Starting service…
[2016-09-23 16:57:28] [info] [ 7416] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:57:29] [info] [ 7416] Running ‘Lucee’ Service…
[2016-09-23 16:57:29] [info] [ 7564] Starting service…

I ended up doing an uninstall, restart, install and then it worked.On Friday, September 23, 2016 at 5:19:28 PM UTC-6, JP wrote:

I am trying to upgrade from Lucee 4.5 to 5 on Windows 7. First I tried
simply replacing the lucee.jar as explained here:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

But after doing it and restarting the Lucee service, I could no longer
access my lucee apps. Instead of troubleshooting, or reverting, I decided
to install from the Windows installer. Before doing that, I did the
following:

  1. Lucee Service wouldn’t stop, so I set it to startup manually and
    restarted my machine.
  2. After restarting, I renamed my old lucee folder to lucee-old because I
    need to restore some tomcat settings.
  3. Then I ran the Windows installer, which failed to start the Lucee
    service.

Now I have a fresh C:\lucee directory, but I cannot start the service.
When I try, it stops immediately. Looking at tomcat logs, I get:

lucee-stdout.2016-09-23.log

2016-09-23 16:57:28 Commons Daemon procrun stdout initialized
Error occurred during initialization of VM
agent library failed to init: instrument

lucee-stderr.2016-09-23.log:

The specified service already exists.

Failed to install service
2016-09-23 16:53:54 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee
-inst.jar

2016-09-23 16:57:28 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee
-inst.jar

commons-daemon.2016-09-23.log

[2016-09-23 16:53:47] [info] [10472] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10472] Service Lucee name Lucee
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [error] [10472] Failed installing ‘Lucee’ service
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [error] [10472] Commons Daemon procrun failed with
exit value: 8 (Failed to install service)
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10304] Updating service…
[2016-09-23 16:53:47] [info] [10304] Service ‘Lucee’ updated
[2016-09-23 16:53:47] [info] [10304] Update service finished.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun finished
[2016-09-23 16:53:54] [info] [ 7944] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:54] [info] [ 7944] Running ‘Lucee’ Service…
[2016-09-23 16:53:54] [info] [11064] Starting service…
[2016-09-23 16:57:28] [info] [ 7416] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:57:29] [info] [ 7416] Running ‘Lucee’ Service…
[2016-09-23 16:57:29] [info] [ 7564] Starting service…

AFAIK you don;t need the instrumentation (railo-inst.jar or as you have put
lucee-inst.jar) . Was this replaced in the service or something?

MD

MDOn 24 September 2016 at 04:21, JP <@JP1> wrote:

I ended up doing an uninstall, restart, install and then it worked.

On Friday, September 23, 2016 at 5:19:28 PM UTC-6, JP wrote:

I am trying to upgrade from Lucee 4.5 to 5 on Windows 7. First I tried
simply replacing the lucee.jar as explained here:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

But after doing it and restarting the Lucee service, I could no longer
access my lucee apps. Instead of troubleshooting, or reverting, I decided
to install from the Windows installer. Before doing that, I did the
following:

  1. Lucee Service wouldn’t stop, so I set it to startup manually and
    restarted my machine.
  2. After restarting, I renamed my old lucee folder to lucee-old because I
    need to restore some tomcat settings.
  3. Then I ran the Windows installer, which failed to start the Lucee
    service.

Now I have a fresh C:\lucee directory, but I cannot start the service.
When I try, it stops immediately. Looking at tomcat logs, I get:

lucee-stdout.2016-09-23.log

2016-09-23 16:57:28 Commons Daemon procrun stdout initialized
Error occurred during initialization of VM
agent library failed to init: instrument

lucee-stderr.2016-09-23.log:

The specified service already exists.

Failed to install service
2016-09-23 16:53:54 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib
lucee-inst.jar

2016-09-23 16:57:28 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib
lucee-inst.jar

commons-daemon.2016-09-23.log

[2016-09-23 16:53:47] [info] [10472] Commons Daemon procrun (1.0.15.0 64
-bit) started
[2016-09-23 16:53:47] [info] [10472] Service Lucee name Lucee
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [error] [10472] Failed installing ‘Lucee’ service
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [error] [10472] Commons Daemon procrun failed with
exit value: 8 (Failed to install service)
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun (1.0.15.0 64
-bit) started
[2016-09-23 16:53:47] [info] [10304] Updating service…
[2016-09-23 16:53:47] [info] [10304] Service ‘Lucee’ updated
[2016-09-23 16:53:47] [info] [10304] Update service finished.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun finished
[2016-09-23 16:53:54] [info] [ 7944] Commons Daemon procrun (1.0.15.0 64
-bit) started
[2016-09-23 16:53:54] [info] [ 7944] Running ‘Lucee’ Service…
[2016-09-23 16:53:54] [info] [11064] Starting service…
[2016-09-23 16:57:28] [info] [ 7416] Commons Daemon procrun (1.0.15.0 64
-bit) started
[2016-09-23 16:57:29] [info] [ 7416] Running ‘Lucee’ Service…
[2016-09-23 16:57:29] [info] [ 7564] Starting service…


Get 10% off of the regular price for this years CFCamp in Munich, Germany
(Oct. 20th & 21st) with the Lucee discount code Lucee@cfcamp. 189€
instead of 210€. Visit https://ti.to/cfcamp/cfcamp-
2016/discount/Lucee@cfcamp


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/lucee/bef360ba-c4fa-4765-991e-b19b388dd6d8%40googlegroups.com
https://groups.google.com/d/msgid/lucee/bef360ba-c4fa-4765-991e-b19b388dd6d8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

Mark, you are correct-- the instrumentation java agent is no longer needed.
It’s loaded dynamically as part of Lucee 5 now. If you include the JVM
arg, it’s just ignored.

Thanks!

~BradOn Monday, September 26, 2016 at 4:07:38 AM UTC-5, Mark Drew wrote:

AFAIK you don;t need the instrumentation (railo-inst.jar or as you have
put lucee-inst.jar) . Was this replaced in the service or something?

MD

MD

On 24 September 2016 at 04:21, JP <@JP1> wrote:

I ended up doing an uninstall, restart, install and then it worked.

On Friday, September 23, 2016 at 5:19:28 PM UTC-6, JP wrote:

I am trying to upgrade from Lucee 4.5 to 5 on Windows 7. First I tried
simply replacing the lucee.jar as explained here:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

But after doing it and restarting the Lucee service, I could no longer
access my lucee apps. Instead of troubleshooting, or reverting, I decided
to install from the Windows installer. Before doing that, I did the
following:

  1. Lucee Service wouldn’t stop, so I set it to startup manually and
    restarted my machine.
  2. After restarting, I renamed my old lucee folder to lucee-old because
    I need to restore some tomcat settings.
  3. Then I ran the Windows installer, which failed to start the Lucee
    service.

Now I have a fresh C:\lucee directory, but I cannot start the service.
When I try, it stops immediately. Looking at tomcat logs, I get:

lucee-stdout.2016-09-23.log

2016-09-23 16:57:28 Commons Daemon procrun stdout initialized
Error occurred during initialization of VM
agent library failed to init: instrument

lucee-stderr.2016-09-23.log:

The specified service already exists.

Failed to install service
2016-09-23 16:53:54 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib
lucee-inst.jar

2016-09-23 16:57:28 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib
lucee-inst.jar

commons-daemon.2016-09-23.log

[2016-09-23 16:53:47] [info] [10472] Commons Daemon procrun (1.0.15.0
64-bit) started
[2016-09-23 16:53:47] [info] [10472] Service Lucee name Lucee
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [error] [10472] Failed installing ‘Lucee’ service
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [error] [10472] Commons Daemon procrun failed with
exit value: 8 (Failed to install service)
[2016-09-23 16:53:47] [error] [10472] The specified service already
exists.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun (1.0.15.0
64-bit) started
[2016-09-23 16:53:47] [info] [10304] Updating service…
[2016-09-23 16:53:47] [info] [10304] Service ‘Lucee’ updated
[2016-09-23 16:53:47] [info] [10304] Update service finished.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun finished
[2016-09-23 16:53:54] [info] [ 7944] Commons Daemon procrun (1.0.15.0
64-bit) started
[2016-09-23 16:53:54] [info] [ 7944] Running ‘Lucee’ Service…
[2016-09-23 16:53:54] [info] [11064] Starting service…
[2016-09-23 16:57:28] [info] [ 7416] Commons Daemon procrun (1.0.15.0
64-bit) started
[2016-09-23 16:57:29] [info] [ 7416] Running ‘Lucee’ Service…
[2016-09-23 16:57:29] [info] [ 7564] Starting service…


Get 10% off of the regular price for this years CFCamp in Munich, Germany
(Oct. 20th & 21st) with the Lucee discount code Lucee@cfcamp. 189€ instead
of 210€. Visit https://ti.to/cfcamp/cfcamp-2016/discount/Lucee@cfcamp


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/bef360ba-c4fa-4765-991e-b19b388dd6d8%40googlegroups.com
https://groups.google.com/d/msgid/lucee/bef360ba-c4fa-4765-991e-b19b388dd6d8%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

I guess I was in a bad state after upgrading Lucee 4.5 by replacing the
.jar file, which didn’t work at all. After uninstalling and then
reinstalling, it worked.On Friday, September 23, 2016 at 5:19:28 PM UTC-6, JP wrote:

I am trying to upgrade from Lucee 4.5 to 5 on Windows 7. First I tried
simply replacing the lucee.jar as explained here:

http://docs.lucee.org/guides/lucee-5/upgrading-lucee-45.html

But after doing it and restarting the Lucee service, I could no longer
access my lucee apps. Instead of troubleshooting, or reverting, I decided
to install from the Windows installer. Before doing that, I did the
following:

  1. Lucee Service wouldn’t stop, so I set it to startup manually and
    restarted my machine.
  2. After restarting, I renamed my old lucee folder to lucee-old because I
    need to restore some tomcat settings.
  3. Then I ran the Windows installer, which failed to start the Lucee
    service.

Now I have a fresh C:\lucee directory, but I cannot start the service.
When I try, it stops immediately. Looking at tomcat logs, I get:

lucee-stdout.2016-09-23.log

2016-09-23 16:57:28 Commons Daemon procrun stdout initialized
Error occurred during initialization of VM
agent library failed to init: instrument

lucee-stderr.2016-09-23.log:

The specified service already exists.

Failed to install service
2016-09-23 16:53:54 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee
-inst.jar

2016-09-23 16:57:28 Commons Daemon procrun stderr initialized
Error opening zip file or JAR manifest missing : C:\lucee\tomcat\lib\lucee
-inst.jar

commons-daemon.2016-09-23.log

[2016-09-23 16:53:47] [info] [10472] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10472] Service Lucee name Lucee
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [error] [10472] Failed installing ‘Lucee’ service
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [error] [10472] Commons Daemon procrun failed with
exit value: 8 (Failed to install service)
[2016-09-23 16:53:47] [error] [10472] The specified service already exists
.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:47] [info] [10304] Updating service…
[2016-09-23 16:53:47] [info] [10304] Service ‘Lucee’ updated
[2016-09-23 16:53:47] [info] [10304] Update service finished.
[2016-09-23 16:53:47] [info] [10304] Commons Daemon procrun finished
[2016-09-23 16:53:54] [info] [ 7944] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:53:54] [info] [ 7944] Running ‘Lucee’ Service…
[2016-09-23 16:53:54] [info] [11064] Starting service…
[2016-09-23 16:57:28] [info] [ 7416] Commons Daemon procrun (1.0.15.0 64-
bit) started
[2016-09-23 16:57:29] [info] [ 7416] Running ‘Lucee’ Service…
[2016-09-23 16:57:29] [info] [ 7564] Starting service…