Updated to but can't downgrade to

I have placed the lucee- file in the /WEB-INF/lucee/lib/ folder and also in the /opt/lucee/lib/ folder (On Ubuntu 16.04) after renaming it to lucee.jar and restarted Lucee but still the admin/Services Update does not show any other options when I click on —select the version —. What have I done wrong?

I want to go back because the new version is giving me errors in the cfspreadsheet extension when I attempt to add images.

You can’t downgrade it from lucee admin, because lucee runs based on the jar file, since you replaced the jar file now you can’t go back to the previous version through lucee admin.

The only way to downgrade is to download the required verison of lucee which you need and replace the jar file in /WEB-INF/lucee/lib/ and /opt/lucee/lib/ with the new downloaded jar file.

could you post a separate thread about the cfspreadsheet errors including stacktraces?

Yes I will thanks Zac

Do I leave it named lucee- or do I rename it to lucee.jar?
I already did copy the downloaded lucee- into both /WEB-INF/lucee/lib/ and /opt/lucee/lib/ but then renamed it to lucee.jar
This was done before I created this post so that obviously didn’t work.

If you have both of the jar file in same directory, lucee will consider the latest one automatically. Name of the jar file does not matter. Just remove the jar file with the version you don’t want.

make sure you have only one lucee.jar in your installation, the one you want, as @cfmitrah pointed out, the name of the jar does not matter at all, in some servlet engine not even the extension matter, if it ends with “.jar” or “.jar.bak” the engine don’t care, if it is a jar it will load it.
if you have multiple version of the same jar in your environment it will simply load one of them, which one depends on the internal listing method of the jvm.

BTW you never need to change the jar at all within one major version, update the core (at lucee-server/patches) is all you need to do. the earliest time the lucee.jar will change is with lucee 6, but atm it looks like not even then it will be necessary.

Thank you for your assistance. I had actually already been doing everything suggested in this thread and the documentation, and the .lco patch, but no matter what I tried I could never bring up an earlier version in the drop down list to downgrade to.
I eventually solved the problem by a complete Lucee uninstall and /opt/lucee folder removal before ground zero reinstalling and reconfiguring my Lucee server instance.