Server-Admin: variable [APIKEY] doesn't exist in Services/Update?

Hey Guys,
in my local Lucee Express Enviroment when i hit Services/Update in my
Server Admin i just get as Info:

server http://dev.lucee.org failed to return a valid response. variable
[APIKEY] doesn’t exist

Probably you already know that the subdomain dev.lucee.org is throwing an
missinginclude error, arent’t you?

Page /dev/index.cfm [/var/www/sites/updateprovider/dev/index.cfm] not found

Thx, Marcus

Oops, haven’t noticed that this issue’s already tracked:
https://bitbucket.org/lucee/lucee/issue/78/services-update-error-server-http

But it doesn’t seem to be a DNS problem because lat update’s 3 days agoAm Donnerstag, 5. Februar 2015 16:44:19 UTC+1 schrieb Marcus:

Hey Guys,
in my local Lucee Express Enviroment when i hit Services/Update in my
Server Admin i just get as Info:

server http://dev.lucee.org failed to return a valid response. variable
[APIKEY] doesn’t exist

Probably you already know that the subdomain dev.lucee.org is throwing an
missinginclude error, arent’t you?

Page /dev/index.cfm [/var/www/sites/updateprovider/dev/index.cfm] not
found

Thx, Marcus

Oops, haven’t noticed that this issue’s already tracked:

https://bitbucket.org/lucee/lucee/issue/78/services-update-error-server-http

But it doesn’t seem to be a DNS problem because lat update’s 3 days ago

I’m getting same thing… the ticket is marked as resolved though…?On Friday, 6 February 2015 04:50:23 UTC+13, Marcus wrote:


Adam

Oops, haven’t noticed that this issue’s already tracked:

https://bitbucket.org/lucee/lucee/issue/78/services-update-error-server-http

But it doesn’t seem to be a DNS problem because lat update’s 3 days ago

I’m getting same thing… the ticket is marked as resolved though…?

Ah, I managed to weed through some other posts and work out what’s going
on. In case anyone else comes across the same issue, here’s my comment from
the bug tracker:

https://bitbucket.org/lucee/lucee/issue/78/services-update-error-server-http#comment-15692555

Aha. There’s some detail missing from this ticket:

It’s fixed in 4.5.1, but because it’s a bug in the updater, one needs to
download and install the update manually. Details here:
https://groups.google.com/forum/#!msg/lucee/OQOICdzNZyo/h2ESdEp3flQJ:

  1. download the “lucee.jar” from here:
    https://bitbucket.org/lucee/lucee/downloads
  2. stop Lucee
  3. replace the existing lucee.jar, with the one you just downloaded
  4. start Lucee

Micha neglects to say where the existing lucee.jar file is, though. For
me it’s: C:\apps\lucee\express\lib\ext (where C:\apps\lucee\express\ is the
base dir I have put my Lucee Express install).

Having done the update manually, the update checker seems to work now.

It’d be really cool if whoever had marked this ticket “resolved” had
included this info on the ticket. And stuff like the release version it had
been fixed in, etc. This isn’t Adobe, guys :wink:

Cheers for fixing though.

And cheers again!On Sunday, 15 February 2015 10:39:54 UTC+13, Adam Cameron wrote:

On Friday, 6 February 2015 04:50:23 UTC+13, Marcus wrote:


Adam