Path mapping issues

I encountered some issues with Lucee 4.5.1.022. I’m wondering if this is a
bug or we are doing something wrong…

If I set the virtual mapping for lucee-context.lar to something other than
/lucee/ I see my changes in lucee-server.xml and in the server admin UI but
any generated lucee-web.xml.cfm will revert to virtual="/lucee/"

The same story with the component base for Component.cfc This also reverts
to /lucee/ if set to any other value in lucee-server.xml

Are these settings supposed to be configurable? I have seen examples
online where people are using /railo-context/ or /lucee-context/ in place
of /lucee/ so I thought that they should be.

Hi Mark,

I think if you change it in the base system lucee-web.xml.cfm it will
copied to new hosts when they are created as I believe it uses the base one
as the template when creating new ones. So if you used the installer this
would be:

{basedir}/tomcat/webapps/ROOT/WEB-INF/lucee/lucee-web.xml.cfm

I must say I’ve not tried this but I think that is how it works.

If you are just trying to stop people from accessing the Lucee Admin I
would suggest using rewrite rules on your web server (Apache, Nginx,
etc…) instead and return a 404 for the admin except for specific IP
addresses. If you want some help with that feel free to contact me off list.

Kind regards,

Andrew
about.me http://about.me/andrew_dixon - mso http://www.mso.net - Lucee
Association Member http://lucee.orgOn 9 July 2015 at 10:14, <@mark.summers> wrote:

I encountered some issues with Lucee 4.5.1.022. I’m wondering if this is
a bug or we are doing something wrong…

If I set the virtual mapping for lucee-context.lar to something other than
/lucee/ I see my changes in lucee-server.xml and in the server admin UI but
any generated lucee-web.xml.cfm will revert to virtual="/lucee/"

The same story with the component base for Component.cfc This also
reverts to /lucee/ if set to any other value in lucee-server.xml

Are these settings supposed to be configurable? I have seen examples
online where people are using /railo-context/ or /lucee-context/ in place
of /lucee/ so I thought that they should be.


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/8a153273-62e1-414a-8aa6-9b178938d741%40googlegroups.com
https://groups.google.com/d/msgid/lucee/8a153273-62e1-414a-8aa6-9b178938d741%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.