Pages loading blank with Lucee 4.5.1.022

I have been having a problem where I am suddenly loading blank pages on a
site that was working several days ago. Over those few days, I had made
many changes to the site so I was sure it was some mistake I made. But
tracking back through my revisions, I found the issue.

As we know, BonCodeAJP13.settings now has
{string}, and that should be added to the
Mod_CFML valve (in server.xml) as: sharedKey="{string}".

So my BonCodeAJP13.settings file looks like this:

8009 localhost 200 0 c:\temp 0 False {myString}

And here:
http://www.modcfml.org/index.cfm/documentation/modcfml-tomcat-valve/config-options/,
we also see that the “shared secret” (aka. ModCFMLSecret and sharedKey and
requiredSecret) should also be added to the mod_cfml valve in Tomcat’s
server.xml file, like this:


Next, the BonCode manual says that we also need to set:
EnableHeaderDataSupport=True

So now my BonCode settings looks like this:

8009 localhost 200 0 c:\temp 0 False True {myString}

So far, so good.

Next, the manual says that our shared secret also needs to be added to the
connector like this:

And here is the issue: When I add the requiredSecret to the
all I get are blank pages in the browser.

But if I remove that requiredSecret, the pages load fine.

Am I doing something wrong, or has something changed since the Manual was
written?

Thanks,

-RR

Maybe your versions of the connector and valve are out of sync ?

TomOn Wednesday, July 29, 2015 at 1:02:20 PM UTC+1, rrho...@gmail.com wrote:

I have been having a problem where I am suddenly loading blank pages on a
site that was working several days ago. Over those few days, I had made
many changes to the site so I was sure it was some mistake I made. But
tracking back through my revisions, I found the issue.

As we know, BonCodeAJP13.settings now has
{string}, and that should be added to the
Mod_CFML valve (in server.xml) as: sharedKey="{string}".

So my BonCodeAJP13.settings file looks like this:

8009 localhost 200 0 c:\temp 0 False {myString}

And here:
http://www.modcfml.org/index.cfm/documentation/modcfml-tomcat-valve/config-options/,
we also see that the “shared secret” (aka. ModCFMLSecret and sharedKey and
requiredSecret) should also be added to the mod_cfml valve in Tomcat’s
server.xml file, like this:


Next, the BonCode manual says that we also need to set:
EnableHeaderDataSupport=True

So now my BonCode settings looks like this:

8009 localhost 200 0 c:\temp 0 False True {myString}

So far, so good.

Next, the manual says that our shared secret also needs to be added to the
connector like this:

And here is the issue: When I add the requiredSecret to the
all I get are blank pages in the browser.

But if I remove that requiredSecret, the pages load fine.

Am I doing something wrong, or has something changed since the Manual was
written?

Thanks,

-RR

As far as mod_cfml is concerned, the “requiredSecret” setting is not necessary in the tag.
You could try to remove that from the tag to see if it helps.
But in the end, Bilal will know what to do…

Cheers, Paul

Next, the manual says that our shared secret also needs to be added to the connector like this:

I have been having a problem where I am suddenly loading blank pages on a site that was working several days ago. Over those few days, I had made many changes to the site so I was sure it was some mistake I made. But tracking back through my revisions, I found the issue.

As we know, BonCodeAJP13.settings now has {string}, and that should be added to the Mod_CFML valve (in server.xml) as: sharedKey="{string}".

So my BonCodeAJP13.settings file looks like this:

8009 localhost 200 0 c:\temp 0 False {myString}

And here: http://www.modcfml.org/index.cfm/documentation/modcfml-tomcat-valve/config-options/, we also see that the “shared secret” (aka. ModCFMLSecret and sharedKey and requiredSecret) should also be added to the mod_cfml valve in Tomcat’s server.xml file, like this:

<Valve className="mod_cfml.core"
	loggingEnabled="false"
	maxContexts="200"
	timeBetweenContexts="2000"
	scanClassPaths="false"
	sharedKey="{myString}"
	/>

Next, the BonCode manual says that we also need to set: EnableHeaderDataSupport=True

So now my BonCode settings looks like this:

8009 localhost 200 0 c:\temp 0 False True {myString}

So far, so good.

Next, the manual says that our shared secret also needs to be added to the connector like this:

And here is the issue: When I add the requiredSecret to the all I get are blank pages in the browser.

But if I remove that requiredSecret, the pages load fine.

Am I doing something wrong, or has something changed since the Manual was written?

Thanks,

-RROp 29 jul. 2015, om 14:02 heeft @rrhodescf het volgende geschreven:


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com mailto:lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/142482ad-5acb-427d-9082-c13b36e47952%40googlegroups.com https://groups.google.com/d/msgid/lucee/142482ad-5acb-427d-9082-c13b36e47952%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.