No css?


I’m fairly new to ubuntu and lucee, so please forgive me if this stupid.

I installed lucee on xubuntu 16.04 with apache 2.4 with IP based virtual host and everything worked fine.

After troubleshooting issues related to virtual host and networking which involved several changes to virtual host conf files, network interfaces and permissions/ownership of www directory, my cfm site still works, but the style-sheet isn’t. pages are completely un-styled.

Can anyone help or point me in right direction to troubleshoot this?


First look in the network section of the developer tools in your web browser and find out what is happening to the request for your CSS file. You will probably see some sort of 4xx HTTP response, probably a 401, 403 or 404 error. Depending on the response code will depend on your next move. If it is 401 or 403 then there is something wrong with the permissions to the file. If it is 404 then there is something wrong with the path to the file. You might also find something useful in the Apache error log file.

Kind regards,


Did you install Lucee as a war in a java context other than the root? The asset paths in the default welcome page are absolute and assume Lucee is in the root.

Thanks Andrew,

I figured it out, I think at one point it didn’t work during configuration and I tried loading the css a couple of different ways. rechecking my index.cfm I found this hybrid line:

I changed the "src" to "href" and it works fine.

I sure feel stupid, but, thanks for getting my focus right.

Best regards,