Missing output since


Just been trying out the newer releases and some requests no longer return data. working backwards thru snapshots everything was working fine till, since the I’m not seeing output inside a function with output=“true” and an abort

i think it’s due to the following commit, the task is flagged as rejected, but I think the commit wasn’t reverted?

setting the flag “Buffer Tag Body Output” to true fixes the problem, but i just wasted 3 hours figuring this out



Wow, sorry to hear about that Zac. I pinged Micha to see if he can take a look at this! cc/ @IamSigmund


it would of been a bit easier if lucee commits had a description…


Added it to my watch list. We’ll (re)investigate. More soon.


@Zac_Spitzer I’m sorry you lost that much time over this!

In older ACF version, ACF did buffer the output even you where inside a silent block and in case of an exception or abort still did output it.
In our opinion this was an invalid behaviour, but still we did follow ACF on this, but we did make it possible to configure it differently in the admin. Also because that behaviour is a big waste of memory and time!

Based on the ticket above we have found out that ACF has changed that behaviour and because of that we changed the DEFAULT behaviour of Lucee as well to be compatible to ACF.

That is the problem of nearly every incompatibility fix, making something more compatible to ACF, could possible break compatibility to older Lucee versions.

Should we reverse that change and keep the default behaviour of older version and wait with that change for Lucee 5.3?

In any case we have to make sure we clearly communicate that change with the release of 5.2.6 or 5.3. @IamSigmund can you please make sure of this i will provide you the necessary info.


I’d say definitely it’s such a breaking change it should only be in 5.3

As per the latest comment in the task, I tried to produce a reduced test case but
I wasn’t able to figure it out

the lucee docs currently say that bufferoutput=true only applies when output=false,
does setting that flag in the admin only apply to tags with output=“true”?

when did ACF change their behaviour?


Ok @micstriit, will do. I’ve got this post flagged, and I’ll make a note to including this in the 5.3 release info.


Was this change was reverted for final?


Hey @Zac_Spitzer. It looks like it was reverted, based on the change logs for 5.2.6 final, but I’ll double-check with @micstriit to be sure. It should be slated for 5.3 only.


Seem it wasn’t, I just downgraded my dev environment to and without “Buffer Tag Body Output” being set it fails

the docs currently say bufferoutput=true only works when output=false which is confusing as output=true no longer works OOTB without bufferoutput=true, which is only available server/context wide?

Cfdump not rendering when output=false
Announcing Lucee 5.2.6 (Final)

Hey Zac. Correct, and sorry for the miscommunication. It was not reverted in 5.2.6 Final ( We’ve released a patch in, and it will be included in 5.3. Anyone who was having a problem with this can just grab from the snapshots page, and you should be good to go.

Zac, I’ll answer your other posts separately.