Lucee5-RC235 memcached extension error

Hi,

I’m trying to install memcached driver extension in Lucee 5 RC235 (express
install) and it throws the error:

Message Unresolved constraint in bundle memcached.extension [82]: Unable to
resolve 82.0: missing requirement [82.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException

Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

how can I fix this ?—
David Sedeño

Hi -

Same with Lucee 5 Stable (5.0.0.252) on a fresh setup using the Express
Edition:

Unresolved constraint in bundle memcached.extension [88]: Unable to resolve
88.0: missing requirement [88.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))

How can this be fixed?

Best,

Hansjoerg

Environment
Version Lucee 5.0.0.252
OS Mac OS X (10.11.5) 64bit
Servlet Container Apache Tomcat/8.0.15
Java 1.8.0_45 (Oracle Corporation) 64bit
Architecture 64bit

Extension
Available version 3.0.2.25
Release Date Jan 22, 2016
Id 16FF9B13-C595-4FA7-B87DED467B7E61A0Am Dienstag, 19. April 2016 10:31:24 UTC+2 schrieb David Sedeño:

Hi,

I’m trying to install memcached driver extension in Lucee 5 RC235 (express
install) and it throws the error:

Message Unresolved constraint in bundle memcached.extension [82]: Unable
to resolve 82.0: missing requirement [82.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException

Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

how can I fix this ?

David Sedeño

This happens on mine too on Windows 2012, so i don’t have any directories
like
“/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101”

Lucee 5.0.0.252 Error (4)
Message Unresolved constraint in bundle memcached.extension [88]: Unable to
resolve 88.0: missing requirement [88.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException
Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2On Tuesday, April 19, 2016 at 9:31:24 AM UTC+1, David Sedeño wrote:

Hi,

I’m trying to install memcached driver extension in Lucee 5 RC235 (express
install) and it throws the error:

Message Unresolved constraint in bundle memcached.extension [82]: Unable
to resolve 82.0: missing requirement [82.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException

Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

how can I fix this ?

David Sedeño

Plus 1

I’m getting the same error. Is this a Lucee issue or an issue with the
extension developer? Or in this case are they one and the same?On Mon, Jun 6, 2016 at 9:38 AM, mee nothus <@mee_nothus> wrote:

This happens on mine too on Windows 2012, so i don’t have any directories
like
“/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101”

Lucee 5.0.0.252 Error (4)
Message Unresolved constraint in bundle memcached.extension [88]: Unable
to resolve 88.0: missing requirement [88.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException
Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

On Tuesday, April 19, 2016 at 9:31:24 AM UTC+1, David Sedeño wrote:

Hi,

I’m trying to install memcached driver extension in Lucee 5 RC235
(express install) and it throws the error:

Message Unresolved constraint in bundle memcached.extension [82]: Unable
to resolve 82.0: missing requirement [82.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException

Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

how can I fix this ?

David Sedeño


Win a ticket to dev.objective from Lucee via Twitter, see
http://bit.ly/1UbTMWj for details, good luck and see you there…

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/42c8509e-ed62-44af-a2e3-166286385295%40googlegroups.com
https://groups.google.com/d/msgid/lucee/42c8509e-ed62-44af-a2e3-166286385295%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

Anybody find a fix for this error. I am working to setup a new Lucee 5
server after all was working correctly on my development machine… and
too many CFhttp errors on a production box.

Problem is we rely heavily on memcache and this error breaks the ability to
install it.

Lucee 5.0.0.252 Error (4)
Message Unresolved constraint in bundle memcached.extension [86]: Unable to
resolve 86.0: missing requirement [86.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException
Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from /Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

Any way to manually install it instead?

Thanks,
JeremyOn Tuesday, April 19, 2016 at 4:31:24 AM UTC-4, David Sedeño wrote:

Hi,

I’m trying to install memcached driver extension in Lucee 5 RC235 (express
install) and it throws the error:

Message Unresolved constraint in bundle memcached.extension [82]: Unable
to resolve 82.0: missing requirement [82.0] osgi.wiring.bundle;
(&(osgi.wiring.bundle=memcached)(bundle-version>=2.5.1))
Cause org.osgi.framework.BundleException

Stacktrace The Error Occurred in
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/ext.applications.cfm:
line 101

called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/web.cfm:
line 389
called from
/Users/mic/Projects/Lucee/Lucee5/core/src/main/cfml/context/admin/server.cfm:
line 2

how can I fix this ?

David Sedeño

Same issue here. I’ve opened
https://luceeserver.atlassian.net/browse/LDEV-900 on it and linked to this
thread.