Lucee Undesirably Answering To Private IP Address


#1

I happen to have a laserjet printer on my network with a reserved static ip address in the range of 10.0.0.0 – 10.255.255.255. All my devices on my network pretty much have reserved static ip addresses. I ran into an issue that I noticed today that I’m no longer able to reach my laserjet printer because Lucee is answering on that IP address. I’ve done zero configuration changes since my last forum post so I’m not sure what to make of this.

My guess is that something that Windows updates has done changed this with IIS, but I haven’t a clue what that could be. Its been many years since managing an IIS server and I don’t recall ever seeing behavior like this before so maybe something else is involved here.


#2

what does ipconfig say? do you have DHCP overlapping the assigned static ranges on your network?


#3

IP addresses are assigned at the OS level and wouldn’t have anything to do with IIS or Lucee directly. My guess would be that your PC does not have a static IP and, as Zac mentioned, is likely getting an IP address from a DHCP server on the network (your router) that overlaps with the static IP’s you already have assigned (to, for example, your printer).


#4

There it is! I didn’t think this was possible. I looked at my WiFi IP address, but nowhere else.

Ethernet adapter vEthernet (Default Switch):

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter
Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-XX
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : XXXX::XXXX:XXXX:XXXX:XXXX%XX(Preferred)
IPv4 Address. . . . . . . . . . . : 10.100.100.100(Preferred) <–The culprit
Subnet Mask . . . . . . . . . . . : 255.255.255.0
IPv4 Address. . . . . . . . . . . : 10.188.187.195(Preferred)

Once I disabled the vEthernet adapter print jobs were released. I’m confused why this adapter thinks its ok to self-assign IP addresses from the pool reserved for DHCP allocation. Anyway, this wasn’t anything to do with Lucee. I’ll see what I can find out about the cause of this mess. Most likely just one more thing not to like about Windows family of OS.