Lucee Service Shutdown problem in Windows


#21

I’ve tried Handle (“handle -p tomcat8.exe”) but found nothing suspicious (I see open Logfiles and Jar-Files and a few more). Actually, the Gateway I’ve created points to a Directory with only one file in it. I’ve also rebooted the server - no success.

The issue can always be reproduced in the following way: Let’s assume, there are two Sites set up in IIS (I’m using mod_cfml by the way): Site A has a DirectoryWatcher gateway defined in it’s web context; Site B hasn’t. I start up Tomcat. If I only call pages on Site B (without gateway), Tomcat will be stopped immediately from the Service Manager. If I start up Tomcat and call a page from Site A (with gateway), Tomcat cannot be stopped. If I start up Tomcat and don’t call any page, Tomcat can be stopped as well…
If you want, we can also schedule a TeamViewer session so I could show the demo “live”?


#22

no need for a live demo, I believe you… does it happen if you don’t use IIS, i.e. call tomcat on 8888 directly?

are you familiar with commandbox? if you could set up a simple reproducable demo with commandbox
it would be awesome, that way the lucee devs can reproduce the problem which is what they need to be able to diagnose the the problem


#23

Good idea. I’ve called http://127.0.0.1/lucee/admin/web.cfm and created a new DirectoryWatcher Event Gateway. Same issue. As soon as gateway is created (and started), Tomcat cannot be stopped. I did some more tests: Start Tomcat - Gateway is startet automatically. Then in Web Manager: STOP the event gateway => Tomcat still cannot be stopped; but it says “stopped” by the event gateway. Kill Tomcat process and restart again. Now, I DELETE the gateway from within the Web Manager: => Tomcat service now can be stopped in the regular way. Conclusion: It doesn’t matter whether the gateway is running or not; I can only Tomcat in a normal way, if there is no gateway defined at all…

I’ve also tried with commandbox:
start cfengine=lucee@5
In the site starting up, I create the same Event Gateway from the web manager. Then, in Commandbox => “stop” => is shutting down immediately/normally.
Actually; in the Server admin under “Servlet container” it tells me “WildFly”. I’m not that familiar with commandbox. Can it also bring up a Tomcat Servlet? I think, the problem is related to TomCat…