[Lucee] I want to serve from /var/www/html/

Hi Bill,

Thank you for the thorough explanation. It is much appreciated by those of us who try to help. =)

(a) Apache still serves html from Port 80

This is probably due to the order you have in your DirectoryIndex. If you have an html file listed first, and an html file is present in your directory, then your HTML file will be shown in preference to your cfm file. If you ONLY want to serve your cfm file by default, I’d recommend adding a DirectoryIndex directive to your virtualhost, and only listing your CFM file there. For example:

<VirtualHost *:80>
ServerName lucee.org
ServerAlias www.lucee.org
DocumentRoot /var/www/html
DirectoryIndex index.cfm
ServerAdmin AN EMAIL ADDRESS
ErrorLog logs/name of server-error_log
CustomLog logs/name of server-access_log common

(b) When I try to call index.cfm from Port 80 (located in /var/www/html/) I
get the Apache error

Service Temporarily Unavailable

There are several possible explanations here. First, when you installed CentOS, did you enable SELinux? Does the user account you have Lucee installed as have sufficient permissions to read the /var/www/html directory? Are you getting any significant errors in your Apache error logs?

Let us know what you find there, and we’ll help more when you report back.

Kind regards,
Jordan Michaels----- Original Message -----
From: “Bill Mitchell” <@Bill_Mitchell>
To: lucee@googlegroups.com
Sent: Thursday, May 28, 2015 1:09:49 AM
Subject: [Lucee] I want to serve from /var/www/html/

Dear Group

I have been a long-term user of ColdFusion starting out when it was still
an Allaire product. I am now stopping using it because I am sick of Adobe
and it is hard to keep secure.

I have now installed Lucee with Tomcat on a Centos 6.6 distribution. I
chose /opt/lucee as the location and port 8888 for the Tomcat server. I
hardened it as per the usual things.

The installation was successful and I connected Apache with Tomcat during
the installation process. I can access the Lucee admin (server/web) from
port 8888 and Apache is serving
html fine from 80.

All my files are served (in CF) from /var/www/html and I want to maintain
that.

I have read a heap of instructions etc about how to change the webroot in
Tomcat.

As best as I could understand I did this:

  1. In the file /opt/lucee/tomcat/conf/server.xml

I added

    <Host name="name of server" appBase="webapps">
         <Context path="" docBase="/var/www/html" />
         <Alias>name of server</Alias>
    </Host>

saved it and restarted lucee

  1. In /etc/httpd/conf/httpd.config I added

<VirtualHost *:80>
ServerAdmin AN EMAIL ADDRESS
DocumentRoot /var/www/html
ServerName name of server
ErrorLog logs/name of server-error_log
CustomLog logs/name of server-access_log common

I also added index.cfm to the DirectoryIndex

I saved it and restarted httpd

Result:

(a) Apache still serves html from Port 80

(b) When I try to call index.cfm from Port 80 (located in /var/www/html/) I
get the Apache error

Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance
downtime or capacity problems. Please try again later.

(b) If I call server_name_domain:8888 I get the contexts of index.cfm in
/var/www/html/

© I can still get

http://e2.newcastle.edu.au:8888/lucee/admin/web.cfm and
http://e2.newcastle.edu.au:8888/lucee/admin/server.cfm

At that stage I am lost.

I guess it is a very simple adjustment and would appreciate help.

I always used stand-alone CF installations (that is not a java servlet set
up).

Thanks in advance.

best wishes
bill


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/fdfeff6a-d5a0-4347-8be5-62a7a16f4d4e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.