[Lucee] cffile copy to S3 failed silently

Have you tried leaving the trailing slash off the destination in cffile? Just a shot in the dark…> On Jun 7, 2016, at 8:44 AM, Peter Pham <@Peter_Pham> wrote:

I have the following code

<cfset S3 = {
accessKeyId = ‘…’
, awsSecretKey = ‘…’
, bucket = ‘…’

I can use and it returns the list of files correctly.
However, copy had failed silently (no error but file was not uploaded at all).
Checking catalina.out , I noticed

07-Jun-2016 22:14:29.182 WARNING [http-nio-8888-exec-5] org.jets3t.service.impl.rest.httpclient.RestStorageService.performRequest Retrying request following error response: PUT ‘/tiger1.png’ – ResponseCode: 307, ResponseStatus: Temporary Redirect, Request Headers: [Date: Tue, 07 Jun 2016 12:14:28 GMT, x-amz-content-sha256: f28fabb188c9dbd3b7daa4331f2da644a5c788f126da9505427f5f4585ec69e4, x-amz-acl: public-read, x-amz-meta-md5-hash: 6c7b05fadebc4675f366e3454bff3b34, Content-MD5: bHsF+t68RnXzZuNFS/87NA==, Content-Type: image/png, Authorization: AWS AKIAIFLYSX5V4VIIKLAQ:TVtctDTgcXT21mBEvKBC/EbHe1Y=, Host: c21dev1.s3-ap-southeast-2.amazonaws.com], Response Headers: [x-amz-request-id: 3A293EBC2D4BB757, x-amz-id-2: 19tJV6Rp9rLqyIxPmzNfgjeGN72cMkPeb4SvbT9PFgo1LcFhhR87VZFo5oSuClTgbYyvw3fucyQ=, Location: https://bucket.s3-ap-southeast-2.amazonaws.com/tiger1.png, Content-Type: application/xml, Transfer-Encoding: chunked, Date: Tue, 07 Jun 2016 12:14:28 GMT, Connection: close, Server: AmazonS3]

The response returned was error code 307.
Is there a way to fix this?

My bucket is at s3-ap-southeast-2
Lucee version: lucee-express-

Win a ticket to dev.objective from Lucee via Twitter, see http://bit.ly/1UbTMWj for details, good luck and see you there…

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/9f99f478-78ec-434f-938a-2b47c88719f3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I have done that but it didn’t work either.
I tested on CF9 with the same code, it was working fine.On Tuesday, 7 June 2016 23:02:15 UTC+10, Sean Daniels wrote:

Have you tried leaving the trailing slash off the destination in cffile?
Just a shot in the dark…