Lucee Application.cfc Cache Settings

Lucee admin notes that you can add cache settings to the Application.cfc
after creation of a cache store. After deleting the original (due to
running in Docker after container restart), I’m getting an error that a
default cache needs to be assigned when starting my app and cacheGet being
called.

Is there a reason something like the following doesn’t create a cache and
mark it as default if there is no cache created in the GUI?

this.cache.connections.selectorCache = {
  class: 'org.lucee.extension.cache.eh.EHCache'
, bundleName: 'ehcache.extension'
, bundleVersion: '2.10.0.17'
, storage: true
, custom: 

{“bootstrapAsynchronously”:“true”,“replicatePuts”:“true”,“automatic_hostName”:"",“bootstrapType”:“on”,“maxelementsinmemory”:“10000”,“manual_rmiUrls”:"",“distributed”:“off”,“automatic_multicastGroupAddress”:“230.0.0.1”,“memoryevictionpolicy”:“LRU”,“replicatePutsViaCopy”:“true”,“timeToIdleSeconds”:“86400”,“maximumChunkSizeBytes”:“5000000”,“automatic_multicastGroupPort”:“4446”,“listener_socketTimeoutMillis”:“120000”,“timeToLiveSeconds”:“86400”,“diskpersistent”:“true”,“manual_addional”:"",“replicateRemovals”:“true”,“replicateUpdatesViaCopy”:“true”,“automatic_addional”:"",“overflowtodisk”:“true”,“replicateAsynchronously”:“true”,“maxelementsondisk”:“10000000”,“listener_remoteObjectPort”:"",“asynchronousReplicationIntervalMillis”:“1000”,“listener_hostName”:"",“replicateUpdates”:“true”,“manual_hostName”:"",“automatic_timeToLive”:“unrestricted”,“listener_port”:""}
, default: ‘object’
};

Wasn’t able to get default to work, but setting the cacheName in all
instances of cache operations works.On Thursday, January 5, 2017 at 3:56:23 PM UTC-5, Alexander Ambrose wrote:

Lucee admin notes that you can add cache settings to the Application.cfc
after creation of a cache store. After deleting the original (due to
running in Docker after container restart), I’m getting an error that a
default cache needs to be assigned when starting my app and cacheGet being
called.

Is there a reason something like the following doesn’t create a cache and
mark it as default if there is no cache created in the GUI?

this.cache.connections.selectorCache = {
  class: 'org.lucee.extension.cache.eh.EHCache'
, bundleName: 'ehcache.extension'
, bundleVersion: '2.10.0.17'
, storage: true
, custom: 

{“bootstrapAsynchronously”:“true”,“replicatePuts”:“true”,“automatic_hostName”:"",“bootstrapType”:“on”,“maxelementsinmemory”:“10000”,“manual_rmiUrls”:"",“distributed”:“off”,“automatic_multicastGroupAddress”:“230.0.0.1”,“memoryevictionpolicy”:“LRU”,“replicatePutsViaCopy”:“true”,“timeToIdleSeconds”:“86400”,“maximumChunkSizeBytes”:“5000000”,“automatic_multicastGroupPort”:“4446”,“listener_socketTimeoutMillis”:“120000”,“timeToLiveSeconds”:“86400”,“diskpersistent”:“true”,“manual_addional”:"",“replicateRemovals”:“true”,“replicateUpdatesViaCopy”:“true”,“automatic_addional”:"",“overflowtodisk”:“true”,“replicateAsynchronously”:“true”,“maxelementsondisk”:“10000000”,“listener_remoteObjectPort”:"",“asynchronousReplicationIntervalMillis”:“1000”,“listener_hostName”:"",“replicateUpdates”:“true”,“manual_hostName”:"",“automatic_timeToLive”:“unrestricted”,“listener_port”:""}
, default: ‘object’
};

Hi Alexander,

It is a 2-step thing: first define the cache, then set it as default with
this.cache.object = ‘cachename’;
this.cache.function = ‘cachename’;
this.cache.etcetera = ‘cachename’;

Kind regards,

Paul KlinkenbergOp 9 jan. 2017, om 17:44 heeft Alexander Ambrose <@Alexander_Ambrose> het volgende geschreven:

Wasn’t able to get default to work, but setting the cacheName in all instances of cache operations works.

On Thursday, January 5, 2017 at 3:56:23 PM UTC-5, Alexander Ambrose wrote:
Lucee admin notes that you can add cache settings to the Application.cfc after creation of a cache store. After deleting the original (due to running in Docker after container restart), I’m getting an error that a default cache needs to be assigned when starting my app and cacheGet being called.

Is there a reason something like the following doesn’t create a cache and mark it as default if there is no cache created in the GUI?

this.cache.connections.selectorCache = {
  class: 'org.lucee.extension.cache.eh.EHCache'
, bundleName: 'ehcache.extension'
, bundleVersion: '2.10.0.17'
, storage: true
, custom: {"bootstrapAsynchronously":"true","replicatePuts":"true","automatic_hostName":"","bootstrapType":"on","maxelementsinmemory":"10000","manual_rmiUrls":"","distributed":"off","automatic_multicastGroupAddress":"230.0.0.1","memoryevictionpolicy":"LRU","replicatePutsViaCopy":"true","timeToIdleSeconds":"86400","maximumChunkSizeBytes":"5000000","automatic_multicastGroupPort":"4446","listener_socketTimeoutMillis":"120000","timeToLiveSeconds":"86400","diskpersistent":"true","manual_addional":"","replicateRemovals":"true","replicateUpdatesViaCopy":"true","automatic_addional":"","overflowtodisk":"true","replicateAsynchronously":"true","maxelementsondisk":"10000000","listener_remoteObjectPort":"","asynchronousReplicationIntervalMillis":"1000","listener_hostName":"","replicateUpdates":"true","manual_hostName":"","automatic_timeToLive":"unrestricted","listener_port":""}
, default: 'object'
};


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com mailto:lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/58cf19d8-b796-4ff4-89e5-21f22096e532%40googlegroups.com https://groups.google.com/d/msgid/lucee/58cf19d8-b796-4ff4-89e5-21f22096e532%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.