Lucee/admin css and js 404

We have one server running Ubuntu 20.04 with Lucee which doesn’t return any css.cfm or js.cfm files in lucee/admin.

I’m a bit lost how to debug this!
Is there a cfm file responsible for delivery of these files?
Where should these files be located?
Any config files to check?

Similar topics didn’t help me to slove this problem.



Hi @gunnar.lieb

Are you directly accessing the site via ?

Or did you install Apache or nginx?

tried all options, same result: 404

All options? So you threw a book at it? Sorry - lack of sleep makes me snarky.

I would uninstall your current installation
as root
rm -rf /opt/lucee (or your path you installed lucee to)
ps -ef killall java (as root)
chmod +x
run through the installer with defaults
then cd /opt/lucee
then start lucee
then navigate to from your local machine
if its not a GUI install, then use lynx or any other text browser
confirm that your browser cache is cleared if GUI

what do the failed requests look like in your browsers dev tools?

Looks like this @Zackster :

@gunnar.lieb I’ve seen this in very few ocasions when something went wrong with a redeployment of the Lucee.jar. Tomcat just failed to create all those files. They just weren’t deployed. What I did was (after backing up the files/folders) completely remove the “WEB-INF” and sometimes also the “lucee-server” directory, then restart Tomcat so that Tomcat recreates the files. I think at that time I’ve started using CommandBox’s cfconfig to easily copy/backup admin settings because removing the files also wiped all the admin settings.

1 Like

check permissions on the user running tomcat / lucee
WEB-INF should have write / execute permissions

permissions are correct

If the permissions and set where correct, you wouldn’t be having an issue.

how about this

Full setup,how is this setup, ubuntu 20.02 lts? server or desktop?
Apache, nginx or tomcat direct?
What is the output of the firewall?

Sorry I need details, as asking for help online you want us to guess, and when I start guessing I come up with things that are just completely snarky as hell.

So please, paste bin, or post your logs and full install details or just start over as right now if you want to say “Its correct” then I am going to say “your wrong”. If you want a second pair of eyes, and help getting this running help us, help you.

Deleted WEB-INF as @andreas suggested. That solved the issue. Thanks everybody!

1 Like