Lucee 5 on Mac OSX, need help with with custom host name

I’m having trouble configuring Lucee on Mac OSX 10.11.5 (El Capitan) to
work from “http://local.luceetest.com:8080”. Basically, Lucee is not
handling requests and .cfm files are returned as plain text. Here’s what I
did:

I installed Lucee 5 by deploying the WAR file - I following these
directions:

http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html
(FYI, step 9, there is no lucee-inst.jar file, so I changed it to
lucee.jar, which does exist)

After the install, Lucee works, and I can access it from
http://localhost:8080 and http://localhost:8080/lucee/admin/web.cfm

Now I want to setup a new app in the host name: “local.luceetest.com” which
I want to map to “/Users/JP/Dev/luceetest/”, so I changed the /etc/hosts
file to include:

127.0.0.1 local.luceetest.com

Then I changed server.xml to include this mapping:

</Host

I added a simple CFM file in: /Users/JP/Dev/luceetest/index.cfm that has

Hello World!

I restarted Tomcat

Now, when I navigate to: http://local.luceetest.com:8080/index.cfm, it’s
delivered as a plain text file, and the entire test file is served with all
the markup:

Hello World!

The good thing is that the file is being served by tomcat, but Lucee is not
getting its hands on it. What am I missing or how can I trace this request
and figure out why Lucee isn’t getting it?

FYI, I used configtest.sh to test my tomcat config and it passes.

Hi JP,

Take a look at the following thread:

https://groups.google.com/forum/#!topic/lucee/fCnBe1_CS6Y

… we’re discussing this same kind of setup there. Basically, you’ll also need to edit your web.xml file and add the handlers that tell Tomcat what to do with Lucee-specific requests.–
Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “JP” <@JP1>
To: “Lucee” lucee@googlegroups.com
Sent: Wednesday, June 22, 2016 2:48:19 PM
Subject: [Lucee] Lucee 5 on Mac OSX, need help with with custom host name

I’m having trouble configuring Lucee on Mac OSX 10.11.5 (El Capitan) to
work from “http://local.luceetest.com:8080”. Basically, Lucee is not
handling requests and .cfm files are returned as plain text. Here’s what I
did:

I installed Lucee 5 by deploying the WAR file - I following these
directions:

http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html
(FYI, step 9, there is no lucee-inst.jar file, so I changed it to
lucee.jar, which does exist)

After the install, Lucee works, and I can access it from
http://localhost:8080 and http://localhost:8080/lucee/admin/web.cfm

Now I want to setup a new app in the host name: “local.luceetest.com” which
I want to map to “/Users/JP/Dev/luceetest/”, so I changed the /etc/hosts
file to include:

127.0.0.1 local.luceetest.com

Then I changed server.xml to include this mapping:

</Host

I added a simple CFM file in: /Users/JP/Dev/luceetest/index.cfm that has

Hello World!

I restarted Tomcat

Now, when I navigate to: http://local.luceetest.com:8080/index.cfm, it’s
delivered as a plain text file, and the entire test file is served with all
the markup:

Hello World!

The good thing is that the file is being served by tomcat, but Lucee is not
getting its hands on it. What am I missing or how can I trace this request
and figure out why Lucee isn’t getting it?

FYI, I used configtest.sh to test my tomcat config and it passes.


Win a ticket to dev.objective from Lucee via Twitter, see http://bit.ly/1UbTMWj for details, good luck and see you there…

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/ad6a2439-deb2-45fe-89c3-381a3a1123a0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

That makes sense… do you have any idea where the paths should go? There
are 2 of them in that config:

lucee-server-directory -> I have it going to /
tomcat/8.5.3/libexec/lucee-server/

lucee-web-directory -> ?? where would this go?On Wednesday, June 22, 2016 at 4:37:04 PM UTC-6, Jordan Michaels wrote:

Hi JP,

Take a look at the following thread:

https://groups.google.com/forum/#!topic/lucee/fCnBe1_CS6Y

… we’re discussing this same kind of setup there. Basically, you’ll also
need to edit your web.xml file and add the handlers that tell Tomcat what
to do with Lucee-specific requests.


Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “JP” <jo...@redtopia.com <javascript:>>
To: “Lucee” <lu...@googlegroups.com <javascript:>>
Sent: Wednesday, June 22, 2016 2:48:19 PM
Subject: [Lucee] Lucee 5 on Mac OSX, need help with with custom host name

I’m having trouble configuring Lucee on Mac OSX 10.11.5 (El Capitan) to
work from “http://local.luceetest.com:8080”. Basically, Lucee is not
handling requests and .cfm files are returned as plain text. Here’s what I
did:

I installed Lucee 5 by deploying the WAR file - I following these
directions:

http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html
(FYI, step 9, there is no lucee-inst.jar file, so I changed it to
lucee.jar, which does exist)

After the install, Lucee works, and I can access it from
http://localhost:8080 and http://localhost:8080/lucee/admin/web.cfm

Now I want to setup a new app in the host name: “local.luceetest.com
which
I want to map to “/Users/JP/Dev/luceetest/”, so I changed the /etc/hosts
file to include:

127.0.0.1 local.luceetest.com

Then I changed server.xml to include this mapping:

</Host

I added a simple CFM file in: /Users/JP/Dev/luceetest/index.cfm that has

Hello World!

I restarted Tomcat

Now, when I navigate to: http://local.luceetest.com:8080/index.cfm, it’s
delivered as a plain text file, and the entire test file is served with
all
the markup:

Hello World!

The good thing is that the file is being served by tomcat, but Lucee is
not
getting its hands on it. What am I missing or how can I trace this request
and figure out why Lucee isn’t getting it?

FYI, I used configtest.sh to test my tomcat config and it passes.


Win a ticket to dev.objective from Lucee via Twitter, see
http://bit.ly/1UbTMWj for details, good luck and see you there…

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.

To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ad6a2439-deb2-45fe-89c3-381a3a1123a0%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

FYI, I got it to work by pointing lucee-web-directory to
/tomcat/8.5.3/libexec/webapps/ROOT/On Wednesday, June 22, 2016 at 4:57:33 PM UTC-6, JP wrote:

That makes sense… do you have any idea where the paths should go? There
are 2 of them in that config:

lucee-server-directory -> I have it going to /
tomcat/8.5.3/libexec/lucee-server/

lucee-web-directory -> ?? where would this go?

On Wednesday, June 22, 2016 at 4:37:04 PM UTC-6, Jordan Michaels wrote:

Hi JP,

Take a look at the following thread:

https://groups.google.com/forum/#!topic/lucee/fCnBe1_CS6Y

… we’re discussing this same kind of setup there. Basically, you’ll
also need to edit your web.xml file and add the handlers that tell Tomcat
what to do with Lucee-specific requests.


Kind regards,
Jordan Michaels
Vivio Technologies

----- Original Message -----
From: “JP” jo...@redtopia.com
To: “Lucee” lu...@googlegroups.com
Sent: Wednesday, June 22, 2016 2:48:19 PM
Subject: [Lucee] Lucee 5 on Mac OSX, need help with with custom host name

I’m having trouble configuring Lucee on Mac OSX 10.11.5 (El Capitan) to
work from “http://local.luceetest.com:8080”. Basically, Lucee is not
handling requests and .cfm files are returned as plain text. Here’s what
I
did:

I installed Lucee 5 by deploying the WAR file - I following these
directions:

http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html
(FYI, step 9, there is no lucee-inst.jar file, so I changed it to
lucee.jar, which does exist)

After the install, Lucee works, and I can access it from
http://localhost:8080 and http://localhost:8080/lucee/admin/web.cfm

Now I want to setup a new app in the host name: “local.luceetest.com
which
I want to map to “/Users/JP/Dev/luceetest/”, so I changed the /etc/hosts
file to include:

127.0.0.1 local.luceetest.com

Then I changed server.xml to include this mapping:

</Host

I added a simple CFM file in: /Users/JP/Dev/luceetest/index.cfm that has

Hello World!

I restarted Tomcat

Now, when I navigate to: http://local.luceetest.com:8080/index.cfm, it’s
delivered as a plain text file, and the entire test file is served with
all
the markup:

Hello World!

The good thing is that the file is being served by tomcat, but Lucee is
not
getting its hands on it. What am I missing or how can I trace this
request
and figure out why Lucee isn’t getting it?

FYI, I used configtest.sh to test my tomcat config and it passes.


Win a ticket to dev.objective from Lucee via Twitter, see
http://bit.ly/1UbTMWj for details, good luck and see you there…

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com.
To post to this group, send email to lu...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/ad6a2439-deb2-45fe-89c3-381a3a1123a0%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.