Lucee- deploy - could not find two jars

When we deploy a .war file with the latest lucee.jar, the following two errors occur:

could not find /bundles/org.lucee.httpcomponents.httpcore-4.4.1.jar in lucee.jar
could not find /bundles/org.lucee.httpcomponents.httpclient-4.5.0.jar in lucee.jar

lucee.jar includes newer versions of these jars:

Tried to deploy on tomcat 7 & 8, same error on both.

We have a client who wants to deploy an application, but the server doesn’t allow outgoing connections, so it fails when trying to download the other two .jar files from the external url.

1 Like

Hi @Darklight,

I’ve successfully deploy lucee jar in lucee on tomcat 7. I can’t get any error related JAR related issue. Can you please check once again after restarting server.

Thanks for your reply!

Our client doesn’t have Lucee on the server and is deploying an application from a WAR file directly with the lucee.jar in there.
The problem isn’t that it can’t deploy - it does if the server allows outgoing connections to download missing jars or wrong versions. But the clients’ servers don’t allow outgoing connections and the newer versions of lucee.jar therefore don’t deploy.