Lucee [4.5.1.022] - org.apache.http.impl.client.HttpClientBuilder.setConnectionTimeToLive

After upgrading to 4.5.1.022 I’m getting the following error:

org.apache.http.impl.client.HttpClientBuilder.setConnectionTimeToLive(JLjava/util/concurrent/TimeUnit;)Lorg/apache/http/impl/client/HttpClientBuilder;

java.lang.NoSuchMethodError

I have some CFHTTP calls with the timeout attribute, and that’s where it
appears to be having issues.

The odd thing is, my staging server doesn’t have the issue, and it’s
running exactly the same app, with the same version of java and the same
jars in the classpath…

Anyone any ideas?

are your http-client jars up to date?

see Konstantinos’ comments in the thread
https://groups.google.com/d/msg/lucee/vEzWtvzPl6Y/e-C4qHFz6sMJ and the
comments in the ticket https://luceeserver.atlassian.net/browse/LDEV-292

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/On 7/4/2015 12:04 PM, Tom Miller wrote:

After upgrading to 4.5.1.022 I’m getting the following error:

org.apache.http.impl.client.HttpClientBuilder.setConnectionTimeToLive(JLjava/util/concurrent/TimeUnit;)Lorg/apache/http/impl/client/HttpClientBuilder;

java.lang.NoSuchMethodError
*
*
I have some CFHTTP calls with the timeout attribute, and that’s where
it appears to be having issues.

The odd thing is, my staging server doesn’t have the issue, and it’s
running exactly the same app, with the same version of java and the
same jars in the classpath…

Anyone any ideas?


You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/da4ba540-06b1-43e0-908f-1bd8674d9e3a%40googlegroups.com
https://groups.google.com/d/msgid/lucee/da4ba540-06b1-43e0-908f-1bd8674d9e3a%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

Hi Igal,

Yep that worked - thanks!

Tom.On Saturday, 4 July 2015 21:03:37 UTC+1, Igal wrote:

are your http-client jars up to date?

see Konstantinos’ comments in the thread
https://groups.google.com/d/msg/lucee/vEzWtvzPl6Y/e-C4qHFz6sMJ and the
comments in the ticket https://luceeserver.atlassian.net/browse/LDEV-292

Igal Sapir
Lucee Core Developer
Lucee.org http://lucee.org/
On 7/4/2015 12:04 PM, Tom Miller wrote:

After upgrading to 4.5.1.022 I’m getting the following error:

org.apache.http.impl.client.HttpClientBuilder.setConnectionTimeToLive(JLjava/util/concurrent/TimeUnit;)Lorg/apache/http/impl/client/HttpClientBuilder;

java.lang.NoSuchMethodError

I have some CFHTTP calls with the timeout attribute, and that’s where it
appears to be having issues.

The odd thing is, my staging server doesn’t have the issue, and it’s
running exactly the same app, with the same version of java and the same
jars in the classpath…

Anyone any ideas?


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+un...@googlegroups.com <javascript:>.
To post to this group, send email to lu...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/da4ba540-06b1-43e0-908f-1bd8674d9e3a%40googlegroups.com
https://groups.google.com/d/msgid/lucee/da4ba540-06b1-43e0-908f-1bd8674d9e3a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.