Japanese Characters using CFDocument not working

This seems to be a problem with CFDocument for years. I have tried
several of the suggestions mentioned on the web but nothing seems to be
working.

We are using Lucee 4.5.2.018 final on Windows 2012 Server.

Here is sample test file

<head>

    <meta charset="utf-8">

 </head>

<body>

Japanese characters below …

愛知県 愛知県

秋田県 秋田県

</body>

Can someone pls point me in the right direction on how to set up our server
so that we can display Japanese characters in our generated PDFs.

Thanks,

Dave

While not a direct answer to your problem. I use Flaying Saucer
(https://github.com/flyingsaucerproject/flyingsaucer) for my PDF generation
needs. It is easier to use and less of a pain than CFDocument.

Andrew PenhorwoodOn Tuesday, April 19, 2016 at 5:32:55 PM UTC-4, Dave Hatz wrote:

This seems to be a problem with CFDocument for years. I have tried
several of the suggestions mentioned on the web but nothing seems to be
working.

We are using Lucee 4.5.2.018 final on Windows 2012 Server.

Here is sample test file

<head>

    <meta charset="utf-8">

 </head>

<body>

Japanese characters below …

愛知県 愛知県

秋田県 秋田県

</body>

Can someone pls point me in the right direction on how to set up our
server so that we can display Japanese characters in our generated PDFs.

Thanks,

Dave

Hi Andrew,
flyingsaucer looks interesting.

Do you have a hint, hot to install it in lucee?
Do I only have to drop the jars in a folder of the java classpath?

Regards
Thorsten

Just drop the jar files on the classpath. There might be an issue the the
iText version being run by Lucee. I believe I just used the latest
iText.jar of the 2.x versions and removed the any others. I am not in a
place to look at my configuration now. I also have some code that creates
the need objects for you to access it from CFML.

I will try to post some code later today.

Andrew PenhorwoodOn Wednesday, April 20, 2016 at 3:56:42 AM UTC-4, thorste...@googlemail.com wrote:

Hi Andrew,
flyingsaucer looks interesting.

Do you have a hint, hot to install it in lucee?
Do I only have to drop the jars in a folder of the java classpath?

Regards
Thorsten

Dave,

I’m curious what you have tried and what has not worked for you. Have you
tried to install a font that will render Japanese on the server? See my
blog post here
https://dnando.github.io/blog/2015/07/01/generating-accurate-pdfs-using-cfdocument/
under Custom fonts.

There are only a very limited set of fonts installed on both ACF and Lucee,
and I somehow doubt they have Japanese characters. You could try installing
a font that does on the server and then add a CSS style within the
cfdocument tag that specifies that the font you installed should be used
for the Japanese characters on the page.

Aria Media Sagl
+41 (0)76 303 4477 cell
skype: ariamediaOn Tue, Apr 19, 2016 at 11:32 PM, Dave Hatz <@Dave_Hatz> wrote:

This seems to be a problem with CFDocument for years. I have tried
several of the suggestions mentioned on the web but nothing seems to be
working.

We are using Lucee 4.5.2.018 final on Windows 2012 Server.

Here is sample test file

<head>

    <meta charset="utf-8">

 </head>

<body>

Japanese characters below …

愛知県 愛知県

秋田県 秋田県

</body>

Can someone pls point me in the right direction on how to set up our
server so that we can display Japanese characters in our generated PDFs.

Thanks,

Dave


Love Lucee? Become a supporter and be part of the Lucee project today! -
http://lucee.org/supporters/become-a-supporter.html

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/a2ea4b46-1ca2-41e6-a863-08e8d32bfe4a%40googlegroups.com
https://groups.google.com/d/msgid/lucee/a2ea4b46-1ca2-41e6-a863-08e8d32bfe4a%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.