Installing CFCSV extension on Lucee 5.2

#1

I have upgraded to latest version of commandbox, which runs Lucee 5.

We have always used CFCSV Lucee extension.

I cannot for the life of me get it installed (nor find install instructions).

I have found this GIT repository: https://github.com/paulklinkenberg/lucee-cfcsv and tried loading both the .zip and .lex files into the extensions section of web/server admin, but the .zip upload sections states file needs to be .lex, and when we upload the .lex we get an error “… is invalid,no Manifest file was found at [META-INF/MANIFEST.MF]”.

Can anyone point me to instructions or tips on how we can get cfcsv installed on Lucee 5.2? We are just going around in circles.

Thanks!

#2

I vaguely remember having a similar issue with Lucee 5.x. I think the comments in https://www.lucee.nl/post.cfm/railo-custom-tag-cfcsv might contain some good pointers.

hth
– Lutz

#3

Hi Lutz,

I have worked through that posting as well, but seemed to refer to Railo or Lucee 4.x installs. Using extension providers etc…

I was unable to find anything on this… it refers to using the method of adding an Extension Providers to the Providers section, but I can’t even find Extension Providers in the CFCSV Repo…

Thanks

I

#4

@JasonM I just tried installing the lex file from the modern folder in that repo into a Lucee 5 install and it seemed to work fine. I uploaded it directly via the server admin and the message was:

Deployed Lucee Extension, see deploy.log for details.

I also checked the server context deploy log and these two lines were there:

“INFO”,“XNIO-1 task-21”,“09/19/2018”,“09:20:43”,“extension”,“deploy tag CSV.cfc”
“INFO”,“XNIO-1 task-21”,“09/19/2018”,“09:20:43”,“extension”,“deploy tag cfcsv/cfcsv.cfc”

If you are still having issues, I’d recommend following up with the author of the extension, Paul Klinkenberg. If you do contact Paul, I’d also recommend he publish his extension to Forgebox.io which acts as an extension provider and makes it much easier for people to install things.

#5

I finally found some time to revisit this one…

I was not able to install the .zip file directly, and changing to .lex also did not work (as per https://www.lucee.nl/post.cfm/railo-custom-tag-cfcsv)…

However I eventually found the lex file to install in the zip file at /dist/modern/extension-cfcsv-…lex.

It was just a case of installing that .lex file as an extension and it went straight in without issue.

Jason

1 Like