IIS Installation Issue

Hi,

I have installed Lucee on a Windows 2008 server using the installer. It
works if I use the port number in the URL, but not if I leave it out. For
example if I use http://myIPaddress:8888 I get the “Welcome To Your Lucee
Installtion” page. If I use http://myIPaddress I get this error:

Generic Connector Communication Error:------------------------------
Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

How do I make IIS work in this situation?

Thanks!

Hi Sarah,

IIS communicates to Tomcat over port 8009, the AJP port:

IIS -> BonCode Connector -> AJP 8009 -> Tomcat -> Lucee Servlet

The error you’re getting is from the BonCode Connector in IIS saying it can’t communicate with Tomcat over the AJP port. Can you verify that Tomcat is online and listening to port 8009? If it is, can you verify that you don’t have a firewall or other security software blocking access to port 8009?

Hope this helps.

-Jordan----- Original Message -----
From: “sarah slyth” <@sarah.slyth>
To: lucee@googlegroups.com
Sent: Tuesday, April 14, 2015 1:25:45 PM
Subject: [Lucee] IIS Installation Issue

Hi,

I have installed Lucee on a Windows 2008 server using the installer. It
works if I use the port number in the URL, but not if I leave it out. For
example if I use http://myIPaddress:8888 I get the “Welcome To Your Lucee
Installtion” page. If I use http://myIPaddress I get this error:

Generic Connector Communication Error:

Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

How do I make IIS work in this situation?

Thanks!


You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/1e393aeb-358e-4251-89ff-1659baaf8e3d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks Jordan…I can telnet to port 8009 and the firewall is not
running. I get the same error. I have one more clue however, if I go to
http://localhost on the server, I get more to the error message:

Generic Connector Communication Error:------------------------------
Please check and adjust your setup:
Ensure that Tomcat is running on given host and port.
If this is a timeout error consider adjusting IIS timeout by changing
executionTimeout attribute in web.config (see manual).

connection between Tomcat and IIS experienced error. Please check log. at BonCodeAJP13.BonCodeAJP13ServerConnection.ConnectionError()
at BonCodeAJP13.BonCodeAJP13ServerConnection.p_CreateConnection(BonCodeAJP13PacketCollection packetsToSend)
at BonCodeIIS.BonCodeCallHandler.ProcessRequest(HttpContext context)

However, I cannot find the BonCode log. The BonCodeAJP13.settings file has this: c:\temp , but no log is created there. Any hints on where to look next?

Sarah :
Can you pro is the full Boncode settings file from the c:\Windows directory.
(This is where the active one should be when using the lucee installer the other ones are samples)

Hi Bilal,

Here are the contents of c:/windows/BonCodeAJP13.settings:

<Settings>
<Server>localhost</Server>
<Port>8009</Port>
<EnableRemoteAdmin>True</EnableRemoteAdmin>
<EnableHeaderDataSupport>True</EnableHeaderDataSupport>
<ForceSecureSession>False</ForceSecureSession>
<AllowEmptyHeaders>False</AllowEmptyHeaders>
</Settings>

Is there anything obvious here? Do I add other server here?On Thursday, April 16, 2015 at 6:59:12 AM UTC-7, Bilal wrote:

Sarah :
Can you pro is the full Boncode settings file from the c:\Windows
directory.
(This is where the active one should be when using the lucee installer the
other ones are samples)

Sarah,
these look like perfectly fine.

A few things to check:

a) Are the tomcat (catalina) log files stating that the AJP port has
started to listen?
b ) Are you running the request on the server, e.g. localhost? If so, the
error message should have displayed a summary stack trace as well? What is
that show?
c) Please verify that you are using the last installed .net framework as
the target framework for your application pool on that site. E.g. if you
installed .net 4 last, change your pool to it.
d) .net framework may not be registered correctly. See troubleshooting
section of documentation:
http://boncode.net/connector/webdocs/Tomcat_Connector.htm
e) There could be another service running on port 8009? Maybe an alternate
tomcat instance. Is it possible to turn them off, then, restart tomcat.

Best,
BilalOn Monday, April 20, 2015 at 5:44:13 PM UTC-4, sarah...@gmail.com wrote:

Hi Bilal,

Here are the contents of c:/windows/BonCodeAJP13.settings:

<Settings>
<Server>localhost</Server>
<Port>8009</Port>
<EnableRemoteAdmin>True</EnableRemoteAdmin>
<EnableHeaderDataSupport>True</EnableHeaderDataSupport>
<ForceSecureSession>False</ForceSecureSession>
<AllowEmptyHeaders>False</AllowEmptyHeaders>
</Settings>

Is there anything obvious here? Do I add other server here?

Thanks for the troubleshooting list Bilal! I was able to fix my problem.
Turns out I failed to update my application pool to .net 4. I updated that
and got a new error (Handler “BonCode-Tomcat-CFM-Handler” has a bad module
“ManagedPipelineHandler” in its module list) which I found in the
documentation linked in your message. I went through that list and until I
got to re-registering .net 4. That fixed it.

Thanks again for the helpful list!On Wednesday, April 22, 2015 at 8:01:38 AM UTC-7, Bilal wrote:

Sarah,
these look like perfectly fine.

A few things to check:

a) Are the tomcat (catalina) log files stating that the AJP port has
started to listen?
b ) Are you running the request on the server, e.g. localhost? If so, the
error message should have displayed a summary stack trace as well? What is
that show?
c) Please verify that you are using the last installed .net framework as
the target framework for your application pool on that site. E.g. if you
installed .net 4 last, change your pool to it.
d) .net framework may not be registered correctly. See troubleshooting
section of documentation:
http://boncode.net/connector/webdocs/Tomcat_Connector.htm
e) There could be another service running on port 8009? Maybe an alternate
tomcat instance. Is it possible to turn them off, then, restart tomcat.

Best,
Bilal

On Monday, April 20, 2015 at 5:44:13 PM UTC-4, sarah...@gmail.com wrote:

Hi Bilal,

Here are the contents of c:/windows/BonCodeAJP13.settings:

<Settings>
<Server>localhost</Server>
<Port>8009</Port>
<EnableRemoteAdmin>True</EnableRemoteAdmin>
<EnableHeaderDataSupport>True</EnableHeaderDataSupport>
<ForceSecureSession>False</ForceSecureSession>
<AllowEmptyHeaders>False</AllowEmptyHeaders>
</Settings>

Is there anything obvious here? Do I add other server here?