From lucee installer to lucee.war / Tomcat / Httpd / proxy

Hello all ,
My level of knowledge and experience with lucee / tomcat (webdev) is pretty novice.
OS: CentOS 6
SElinux: disabled

We have coldfusion website wich works fine when used with the lucee full installer.

I am asked to make the website work with a separate install of httpd / tomcat / java and the lucee.war.

So far i have succesfully installed httpd, i have made proxy entry in my httpd with the following config:
https://pastebin.com/uRbTSax1

I have made a vhost entry with the follwing
https://pastebin.com/SbJGEunZ

I have installed tomcat and the lucee.war according to these instructions.


http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html
When i access my host on port 8080 using the ip of the server i get a page of lucee displaying my install was succesfull
When i access test.nl on port 80 or port 8080 i get an error page
If i access my server on port 80 i get to see the code of a cfm file not that coldfusion page

I have searched the internet for instructions:

  • I have tried to create a site in ./tomcat/conf/server.xml

I have the following questions:
I have tried to add a site to tomcat in ./tomcat/conf/server.xml
The server.xml has the following:
https://pastebin.com/z1cydYxR

I have edited my /usr/tomcat/conf/web.xml
https://pastebin.com/MdA7KHVm

But so far no luck, help would be appreciated.

When i open the site i get to see this screen:

After editing the web.xml i see this:

Arche

What domain are you hitting in the URL? If it’s not test.nl, then you’re going to be hitting the default host which is configured as localhost and has the web root of the war in webapps/root.

I’m curious, is there a particular reason you’re avoiding the installer? You’re basically just having to reproduce all the changes that the installer does, but in a must more laborious and error-prone manner :slight_smile:

Also, trying to create all your hosts is a real pain. I would install mod_cfml into Apache and add the servlet filter into Tomcat which auto-creates the Tomcat hosts for you based on your virtual directories in Apache (which is basically how Adobe CF works, more less). Of course, this is all done for you if you just use the installer!

Thank you for responding

I am not using test.nl, i anonymised that entry. I have made my client and the server make the entry point to the correct server

The reason that i am not using the installer is because it will be deployed where Apache, Tomcat are required to be installed seperatly. This choice is not mine to challenge

I have installed mod_cfm into Apache.
What do you mean by: “add the servlet filter”

Check out the docs for mod cfml. There is a jar you drop in the tomcat lib folder and then add an XML snippet to the config. Let me see if I can find it.
Oops, I called it the wrong thing, it’s a tomcat valve!
http://www.modcfml.org/index.cfm/documentation/modcfml-tomcat-valve/

And to confirm, the host domain in your browser URL is an exact match for the host in your server.xml? Because the error tells me that the default host is getting used that point to the web root of webapps/root/etc

Meanwhile i have tried multiple things(at point of writing i had a host entry in server.xml, wich can bee seen in the past.bin)
At this point i have made a site bij adding a xml in ./tomcat/conf/Catalina/localhost/test.xml

So if i fooled my client os (Window - c:\windows\system32\drivers\etc\hosts) and linux in /etc/hosts that test.nl lives on my linux host

I think i also loaded the tomcat valve somewhere during this day

But to be honest, my head is spinning at this time, so ill review my settings tommorow and share my findings.

Had to confirm some stuff here for disclosure.
We have made a reinstall, so to be sure that any hacking done previously is not in the way

The host we are trying to display with the lucee.war is http://www.xxx.nl
We are using centos 6 with selinux disabled

We have installed httpd with the following config:
https://pastebin.com/PQ41rccn

We have installed a vhost with the following config:
https://pastebin.com/6MXsfPcm

We have installed tomcat 8.0.46 in /usr
We have now sucessfully deployed the lucee war as lucee5 (the war is named lucee5.war)
We have not made any host in /usr/tomcat/conf/server.xml

The CFML file are in /home/getij/stage2/public_html

With the current config we get this error:

We have also sucessfully installed cfml-mod_valve in tomcat

Can you give as guidance on how to proceed?

I have openend a new topic since the current setup is different:
-https://dev.lucee.org/t/followup-from-lucee-installer-to-lucee-war/2787-