Error with extensions after downgrading from 5.3


#1

I upgrade to Lucee 5.3 a while back and realized it wouldn’t work for us because of the breaking change to . I used the web interface to downgrade back to 5.2.9.31 and everything went fine but the extensions page gives me the error “The Extension [Axis 1 Webservices : 1.4.0.24-ALPHA] cannot be loaded, Lucee Version must be at least [5.3.0.20], version is [5.2.9.31].” and will not load anymore. I have gone through the lucee-server.xml file and removed all references and also removed the matching bundle file under the lucee-server directory. However I am still getting the error. Is there another spot I might be missing that is referencing this extension?


#2

Hi @Yamaha32088,

In my local, I’ve upgrade the lucee from 5.2.9.31 into 5.3.2.47-snapshot version. Then again i downgrade it into 5.2.9.32-snapshot. It doesn’t throw any error when i see the list of extension under application. For 5.3 no more releases available & couldn’t able to downgrade the current version into 5.2.9.31.
Note: I did the updgrade/downgrade action via admin panel.
Can you please elaborate your step for upgrading & downgrading. It’ll helpful to reproduce the issue.


#3

I did the same thing you did.


#4

OK. Where did you see the error? From the server UI or any other log file?


#5

I have the pretty the same error like Yamaha32088 after downgrading from 5.3 to 5.2.
I was testing a 5.3 Alpha Version and than switched back. Never got rid of this error…


#6

In the server UI. Same as what David just posted above, just a different extension of course.