Error in latest installer lucee-4.5.1.022-pl1-linux-x64-installer.run

Hello,

I received the following error while trying a fresh install of Lucee on
CentOS 6.7 x64

Error running /opt/lucee/sys/install_mod_cfml.sh -m install -f
/etc/httpd/conf/httpd.conf -d /usr/lib64/httpd/modules -c
/usr/sbin/apachectl -k
XXX :
/opt/lucee/sys/install_mod_cfml.sh: line 486: ModCFML_SharedKey
“${$mySecretKey}”: bad substitution

Where XXX was my shared key, which I omitted in this post

When hitting sites configured via vhosts, Tomcat throws the following
error: “mod_cfml request authentication failed!”

*WORKAROUND: *

Based on searching, I got around this error by adding a line to the Apache
config
(http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/):

ModCFML_SharedKey “secret key also set in the Tomcat valve config”

Which the secret key was found in the /opt/lucee/tomcat/conf/server.xml

This post was of
assistance: https://groups.google.com/forum/#!topic/lucee/z40E_1mCtWQ

Hi Rory,

What is the md5sum of the installer you’re using? It should be:

$ md5sum lucee-4.5.1.022-pl1-linux-x64-installer.run
017b819f2b47e7edb1d47a575d1d2893 lucee-4.5.1.022-pl1-linux-x64-installer.run

You may simply need to re-download. I’ve verified the md5sum on http://lucee.viviotech.net/

Kind regards,
Jordan Michaels----- Original Message -----
From: “Rory Laitila” <@Rory_Laitila>
To: “Lucee” lucee@googlegroups.com
Sent: Sunday, September 13, 2015 12:36:07 PM
Subject: [Lucee] Error in latest installer lucee-4.5.1.022-pl1-linux-x64-installer.run

Hello,

I received the following error while trying a fresh install of Lucee on
CentOS 6.7 x64

Error running /opt/lucee/sys/install_mod_cfml.sh -m install -f
/etc/httpd/conf/httpd.conf -d /usr/lib64/httpd/modules -c
/usr/sbin/apachectl -k
XXX :
/opt/lucee/sys/install_mod_cfml.sh: line 486: ModCFML_SharedKey
“${$mySecretKey}”: bad substitution

Where XXX was my shared key, which I omitted in this post

When hitting sites configured via vhosts, Tomcat throws the following
error: “mod_cfml request authentication failed!”

*WORKAROUND: *

Based on searching, I got around this error by adding a line to the Apache
config
(http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/):

ModCFML_SharedKey “secret key also set in the Tomcat valve config”

Which the secret key was found in the /opt/lucee/tomcat/conf/server.xml

This post was of
assistance: https://groups.google.com/forum/#!topic/lucee/z40E_1mCtWQ


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/43d21fcc-e80b-4479-83e0-2b62f5507a36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Jordan,

fd14730fc2afa116d63fe61fd6b75842
lucee-4.5.1.022-pl1-linux-x64-installer.run

This was the URL pulled from lucee.org:

wget
http://lucee.viviotech.net/downloader.cfm/id/136/file/lucee-4.5.1.022-pl1-linux-x64-installer.run

I just downloaded it again to be sure:

fd14730fc2afa116d63fe61fd6b75842
lucee-4.5.1.022-pl1-linux-x64-installer.runOn Mon, Sep 14, 2015 at 2:09 PM, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Rory,

What is the md5sum of the installer you’re using? It should be:

$ md5sum lucee-4.5.1.022-pl1-linux-x64-installer.run
017b819f2b47e7edb1d47a575d1d2893
lucee-4.5.1.022-pl1-linux-x64-installer.run

You may simply need to re-download. I’ve verified the md5sum on
http://lucee.viviotech.net/

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Rory Laitila” <@Rory_Laitila>
To: “Lucee” lucee@googlegroups.com
Sent: Sunday, September 13, 2015 12:36:07 PM
Subject: [Lucee] Error in latest installer
lucee-4.5.1.022-pl1-linux-x64-installer.run

Hello,

I received the following error while trying a fresh install of Lucee on
CentOS 6.7 x64

Error running /opt/lucee/sys/install_mod_cfml.sh -m install -f
/etc/httpd/conf/httpd.conf -d /usr/lib64/httpd/modules -c
/usr/sbin/apachectl -k
XXX :
/opt/lucee/sys/install_mod_cfml.sh: line 486: ModCFML_SharedKey
“${$mySecretKey}”: bad substitution

Where XXX was my shared key, which I omitted in this post

When hitting sites configured via vhosts, Tomcat throws the following
error: “mod_cfml request authentication failed!”

*WORKAROUND: *

Based on searching, I got around this error by adding a line to the Apache
config
(
http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/
):

ModCFML_SharedKey “secret key also set in the Tomcat valve config”

Which the secret key was found in the /opt/lucee/tomcat/conf/server.xml

This post was of
assistance: https://groups.google.com/forum/#!topic/lucee/z40E_1mCtWQ


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/43d21fcc-e80b-4479-83e0-2b62f5507a36%40googlegroups.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/FgojF0gqBWM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/244383768.19551.1442254196720.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.


Rory Laitila
itr8group.com
248-752-2428

That was a much more troublesome problem with the download app then it should have been…

Please try downloading one more time. You should get the proper file with the proper md5sum this time.

My sincere apologies for the trouble.

Kind regards,
Jordan Michaels----- Original Message -----
From: “Rory Laitila” <@Rory_Laitila>
To: lucee@googlegroups.com
Sent: Monday, September 14, 2015 2:21:13 PM
Subject: Re: [Lucee] Error in latest installer lucee-4.5.1.022-pl1-linux-x64-installer.run

Hi Jordan,

fd14730fc2afa116d63fe61fd6b75842
lucee-4.5.1.022-pl1-linux-x64-installer.run

This was the URL pulled from lucee.org:

wget
http://lucee.viviotech.net/downloader.cfm/id/136/file/lucee-4.5.1.022-pl1-linux-x64-installer.run

I just downloaded it again to be sure:

fd14730fc2afa116d63fe61fd6b75842
lucee-4.5.1.022-pl1-linux-x64-installer.run

On Mon, Sep 14, 2015 at 2:09 PM, Jordan Michaels <@Jordan_Michaels> wrote:

Hi Rory,

What is the md5sum of the installer you’re using? It should be:

$ md5sum lucee-4.5.1.022-pl1-linux-x64-installer.run
017b819f2b47e7edb1d47a575d1d2893
lucee-4.5.1.022-pl1-linux-x64-installer.run

You may simply need to re-download. I’ve verified the md5sum on
http://lucee.viviotech.net/

Kind regards,
Jordan Michaels

----- Original Message -----
From: “Rory Laitila” <@Rory_Laitila>
To: “Lucee” lucee@googlegroups.com
Sent: Sunday, September 13, 2015 12:36:07 PM
Subject: [Lucee] Error in latest installer
lucee-4.5.1.022-pl1-linux-x64-installer.run

Hello,

I received the following error while trying a fresh install of Lucee on
CentOS 6.7 x64

Error running /opt/lucee/sys/install_mod_cfml.sh -m install -f
/etc/httpd/conf/httpd.conf -d /usr/lib64/httpd/modules -c
/usr/sbin/apachectl -k
XXX :
/opt/lucee/sys/install_mod_cfml.sh: line 486: ModCFML_SharedKey
“${$mySecretKey}”: bad substitution

Where XXX was my shared key, which I omitted in this post

When hitting sites configured via vhosts, Tomcat throws the following
error: “mod_cfml request authentication failed!”

*WORKAROUND: *

Based on searching, I got around this error by adding a line to the Apache
config
(
http://www.modcfml.org/index.cfm/documentation/modcfml-so-apache-module/config-options/
):

ModCFML_SharedKey “secret key also set in the Tomcat valve config”

Which the secret key was found in the /opt/lucee/tomcat/conf/server.xml

This post was of
assistance: https://groups.google.com/forum/#!topic/lucee/z40E_1mCtWQ


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/43d21fcc-e80b-4479-83e0-2b62f5507a36%40googlegroups.com
.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your
ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to a topic in the
Google Groups “Lucee” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/lucee/FgojF0gqBWM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/244383768.19551.1442254196720.JavaMail.zimbra%40viviotech.net
.
For more options, visit https://groups.google.com/d/optout.


Rory Laitila
itr8group.com
248-752-2428


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/CANm8moQdMmCXh3w465fsLbkT4AK1uqGp2JvQqbd7Oin1BJ5FuQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.