Email not sending Lucee 5.3.5.92

any clues in the mail server logs?

No, not really, the mail server log does not give any useful hint:
EHLO 250
QUIT 240

Do you get an exception like the OP? The OP’s exception is occurring totally in Java.
I had something important with work and haven’t had a chance to get back to it.

Try an SMTP test program like SMTP diag first.

Enable java mail debug via a JVM argument
https://javaee.github.io/javamail/FAQ#debug

I couldn’t get the debug argument to work with Express under Windows. I think it is supposed to work with Services but haven’t tested.

I’ll have to add my voice to this. Same problem on anything above 5.3.4.80 with a simple cfmail call to a port 25 email server. I have no hair, but I’d be tearing it out if I did.

I’m not sure what the difficulty has been in replicating and fixing this, but I can replicate with a commandbox instance on Windows running various Lucee versions and connecting to a Windows mailenable mail server - I’d be happy to set up a test mailbox on that if someone would find it useful. Still a showstopper issue in several production builds.

I was having the same issue with lucee 5.3.6.x I think it was. I downgraded to 5.3.4.80 listed in the above comments and it started working again.

My issues persists in 5.3.8.12-SNAPSHOT.
When adding -Dmail.debug=true will there be a separate logfile written?

I think they get written out either into the tomcat logs under C:\lucee\tomcat\logs or the C:\lucee\tomcat\lucee-server\context\logs

Check the catalina-xxx.log or err.log or out.log files and report back?

Any updates to this? I’m encountering the same issue…have tried upgrading JRE and tried the RC 5.3.7.34-RC as well , with no success.

Still no progress with 5.3.8.74-SNAPSHOT
I’m a bit disappointed, that a basic feature does not get addressed.

1 Like

@Zackster @micstriit Just bumping this way so you can comment. Agree with above that it’s basic functionality that’s gotten broken sometime around 5.3.4.80 . I had to downgrade as well to be able to send cfmail’s. Thanks.

Trust me, I’ve been banging on about getting this fixed for ages.

All I can suggest is making a donation to Lucee and asking for this to be prioritised.

How much of a donation? :smile: Do we know what the cause is - sounds like conflicting libraries?

my guess is a bit of that, and class loader issues, plus the javamail is quite old in lucee (1.4.7, latest is 1.6.5) https://luceeserver.atlassian.net/browse/LDEV-2618

all donations help the project, often companies privately sponsor various improvements

Let me check. Testing the problem months ago, I think I was just modifying the MANIFEST.MF file in the .lco and I made javax.mail.activation jars. Let me double check how I did it and I will post instructions. You can then use a newer mail jar.

OK. Here is what I did for my CommandBox in windows. Used 7-Zip to edit file

  1. Shutdown Lucee
  2. Copy the latest lucee-server\patches .lco file somewhere to edit
  3. The .lco is zip file. Edit the META-INF\MANIFEST.MF file. (Right click and edit for 7-zip Windows)
  4. Search for javax.mail and change the bundle-version next to it from “1.4.7.002L” to “1.5.6”
    (Make sure to save the .lco with the updated MANIFEST.MF)
  5. Download my new javax.mail jar:
    https://www.houstonuniform.com/lucee/javax.mail.activation-1.5.6.jar
  6. Copy the jar to lucee-server\bundles
  7. Start Lucee.
  8. Copy the UPDATED .lco to the lucee-server\deploy folder and wait for Lucee to deploy it.
1 Like

I make monthly donations and this really is a basic necessity that we need too. How can I vote for this?

Did you see this?

1 Like