Do not send email before restarting Lucee


Recently there was a problem that the email is no longer sent.
We restart Lucee and the problem disappears for a while.

Lucee mail config (disabled tls and ssl)

this.mailservers =[ {
	  host: ''
	, port: 25
	, username: 'cs@[deleted].com'
	, password: 'encrypted:[deleted]'
	, ssl: false
	, tls: false
	, lifeTimespan: createTimeSpan(0,0,1,0)
	, idleTimespan: createTimeSpan(0,0,1,0)

20 Maximum concurrent threads are set.

If you set the parameter to async = false, test script hangs and does not execute.

Mail server - Smarter Mail with disabled tls and ssl.

I see in the problem .tsk file “portI spoolI sslI atimeout” .
As a new user - I can not attach a file. I posted a file in the dropbox -

Any idea what might be the problem? What other logs do you need to attach to identify the problem?



Hi @delfi,

In which lucee version did you reproduced this issue?


Hi, @cfmitrah

Thanks for your response

General Info
Version Lucee
Version Name Velvet
Release date Oct 10, 2017
ColdFusion® compatibility version 2016.0.03.300357

And additional info :
OS Windows Server 2012 R2 (6.3) 64bit
Servlet Container Apache Tomcat/8.0.35
Java 1.8.0_131 (Oracle Corporation) 64bit
Architecture 64bit