Change Lucee to 32bit Java

My box is a Windows 2012 R2 (64bit) and I installed Lucee with the Windows
installer from the downloads section on lucee.org. How can I change Lucee
to use a 32bit java instead of 64bit?

Thanks,
Chris

Is it not just a matter of downloading a 64 bit JVM?

My set up
Configuration File
C:\websites\lucee-5-express\lucee-server\context\lucee-server.xmlOSWindows
8.1 (6.3) 64bitRemote IP0:0:0:0:0:0:0:1Host NamelocalhostServlet
ContainerApache
Tomcat/8.0.15Java1.8.0_40 (Oracle Corporation) 64bitArchitecture64bitOn 16 April 2015 at 00:27, <@Chris> wrote:

My box is a Windows 2012 R2 (64bit) and I installed Lucee with the Windows
installer from the downloads section on lucee.org. How can I change
Lucee to use a 32bit java instead of 64bit?

Thanks,
Chris


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/a9c1ad05-bfb7-47d7-8dd2-2182878fb0c9%40googlegroups.com
https://groups.google.com/d/msgid/lucee/a9c1ad05-bfb7-47d7-8dd2-2182878fb0c9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

AJ Mercer
<webonix:net strength=“Industrial” /> http://webonix.net | <webonix:org
community=“Open” /> http://webonix.org
http://twitter.com/webonix

I did look at that, but the access 64bit driver is very buggy. I would get
[Microsoft][ODBC Driver Manager] Invalid string or buffer length.

I’m testing
http://www.easysoft.com/products/data_access/jdbc-access-gateway/index.html#section=tab-1
and it seems to be working good.

I can’t wait to not have to deal with Access anymore. :slight_smile:

ChrisOn Thursday, April 16, 2015 at 12:29:52 PM UTC-4, Sean Corfield wrote:

On Apr 16, 2015, at 9:27 AM, Chris <pfef...@gmail.com <javascript:>> wrote:

To connect to Access

Sorry :slight_smile:

I guess you did something like this:

http://www.selikoff.net/2011/07/26/connecting-to-ms-access-file-via-jdbc-in-64-bit-java/

Sean Corfield – (904) 302-SEAN
An Architect’s View – http://corfield.org/

“Perfection is the enemy of the good.”
– Gustave Flaubert, French realist novelist (1821-1880)

Sorry :slight_smile:

I guess you did something like this:

http://www.selikoff.net/2011/07/26/connecting-to-ms-access-file-via-jdbc-in-64-bit-java/ http://www.selikoff.net/2011/07/26/connecting-to-ms-access-file-via-jdbc-in-64-bit-java/

Sean Corfield – (904) 302-SEAN
An Architect’s View – http://corfield.org/

“Perfection is the enemy of the good.”
– Gustave Flaubert, French realist novelist (1821-1880)On Apr 16, 2015, at 9:27 AM, Chris <@Chris> wrote:

To connect to Access

Lucee’s bytecode is the same for 32b and 64b. simply run a 32b JVM to get
it in 32b.

the startup script can be easily modified to point to a different JRE, or
use the Tomcat applet to specify the JVM path in the Java tab.

also, you might want to convert the database once to something like H2 and
do away with Access once and for all.On Thu, Apr 16, 2015 at 9:37 AM, Chris <@Chris> wrote:

I did look at that, but the access 64bit driver is very buggy. I would
get [Microsoft][ODBC Driver Manager] Invalid string or buffer length.

I’m testing
http://www.easysoft.com/products/data_access/jdbc-access-gateway/index.html#section=tab-1
and it seems to be working good.

I can’t wait to not have to deal with Access anymore. :slight_smile:

Chris

On Thursday, April 16, 2015 at 12:29:52 PM UTC-4, Sean Corfield wrote:

On Apr 16, 2015, at 9:27 AM, Chris pfef...@gmail.com wrote:

To connect to Access

Sorry :slight_smile:

I guess you did something like this:

http://www.selikoff.net/2011/07/26/connecting-to-ms-access-file-via-jdbc-in-64-bit-java/

Sean Corfield – (904) 302-SEAN
An Architect’s View – http://corfield.org/

“Perfection is the enemy of the good.”
– Gustave Flaubert, French realist novelist (1821-1880)


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/61bcf4f2-3d02-46bc-8992-c8da0ddf3de7%40googlegroups.com
https://groups.google.com/d/msgid/lucee/61bcf4f2-3d02-46bc-8992-c8da0ddf3de7%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

Check in folder:

lucee\tomcat\bin

you will find a tool “Luceew.exe” it will allow you to change JVM used by
tomcat. That would do the trick easily or allow you to upgrade JDK, or even
use the same as Coldfusion if you have them on the same box like I did ;-).

More over JRE change here:
http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

M BOn Wednesday, April 15, 2015 at 6:27:21 PM UTC+2, Chris wrote:

My box is a Windows 2012 R2 (64bit) and I installed Lucee with the Windows
installer from the downloads section on lucee.org. How can I change
Lucee to use a 32bit java instead of 64bit?

Thanks,
Chris

Dear all,

I have to support a legacy application that imports data from Access
databases. Today I had to move the application to a server running Windows
2012 R2 and ran of course into the JDBC issue mentioned here.

I’m happy to report that I managed to use the UCanaccess project driver
(http://sourceforge.net/projects/ucanaccess/) with Lucee. Requires no ODBC
object and connects nicely to the MDB files.

Having to support MDBs is actually the only reason why the server in
question is running Windows, so I’ll see if UCanaccess is also usable with
*nix boxes. Thought I’d share this in case somebody else has MDB pains,
too…

Rgds
LutzOn Wednesday, 22 April 2015 20:14:09 UTC+2, Mehdi B wrote:

Check in folder:

lucee\tomcat\bin

you will find a tool “Luceew.exe” it will allow you to change JVM used by
tomcat. That would do the trick easily or allow you to upgrade JDK, or even
use the same as Coldfusion if you have them on the same box like I did ;-).

More over JRE change here:
http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

M B

On Wednesday, April 15, 2015 at 6:27:21 PM UTC+2, Chris wrote:

My box is a Windows 2012 R2 (64bit) and I installed Lucee with the
Windows installer from the downloads section on lucee.org. How can I
change Lucee to use a 32bit java instead of 64bit?

Thanks,
Chris

That’s pretty sweet. Have you used UCanAccess with a Linux system yet?
Can you access MDB files on Linux then?

Thank you for letting the community know!

Warm Regards,
Jordan MichaelsOn 09/01/2015 12:09 PM, @lutz wrote:

Dear all,

I have to support a legacy application that imports data from Access
databases. Today I had to move the application to a server running
Windows 2012 R2 and ran of course into the JDBC issue mentioned here.

I’m happy to report that I managed to use the UCanaccess project driver
(http://sourceforge.net/projects/ucanaccess/) with Lucee. Requires no
ODBC object and connects nicely to the MDB files.

Having to support MDBs is actually the only reason why the server in
question is running Windows, so I’ll see if UCanaccess is also usable
with *nix boxes. Thought I’d share this in case somebody else has MDB
pains, too…

Rgds
Lutz

On Wednesday, 22 April 2015 20:14:09 UTC+2, Mehdi B wrote:

Check in folder:

lucee\tomcat\bin

you will find a tool "Luceew.exe" it will allow you to change JVM
used by tomcat. That would do the trick easily or allow you to
upgrade JDK, or even use the same as Coldfusion if you have them on
the same box like I did ;-).

More over JRE change here:
http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat
<http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat>

M B


On Wednesday, April 15, 2015 at 6:27:21 PM UTC+2, Chris wrote:

    My box is a Windows 2012 R2 (64bit) and I installed Lucee with
    the Windows installer from the downloads section on lucee.org
    <http://lucee.org>.  How can I change Lucee to use a 32bit java
    instead of 64bit?

    Thanks,
    Chris


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get
your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/762b9ef4-93a0-4c64-a856-f3c5f916806c%40googlegroups.com
https://groups.google.com/d/msgid/lucee/762b9ef4-93a0-4c64-a856-f3c5f916806c%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.

Ha. In my excitement I didn’t fully comprehend your last statement. I’ll just eagerly wait to hear how it goes for you on Linux. :wink:

Thanks again!

-Jordan----- Original Message -----
From: “Jordan Michaels” <@Jordan_Michaels>
To: lucee@googlegroups.com
Sent: Tuesday, September 1, 2015 12:22:05 PM
Subject: Re: [Lucee] Re: Change Lucee to 32bit Java

That’s pretty sweet. Have you used UCanAccess with a Linux system yet?
Can you access MDB files on Linux then?

Thank you for letting the community know!

Warm Regards,
Jordan Michaels

On 09/01/2015 12:09 PM, @lutz wrote:

Dear all,

I have to support a legacy application that imports data from Access
databases. Today I had to move the application to a server running
Windows 2012 R2 and ran of course into the JDBC issue mentioned here.

I’m happy to report that I managed to use the UCanaccess project driver
(http://sourceforge.net/projects/ucanaccess/) with Lucee. Requires no
ODBC object and connects nicely to the MDB files.

Having to support MDBs is actually the only reason why the server in
question is running Windows, so I’ll see if UCanaccess is also usable
with *nix boxes. Thought I’d share this in case somebody else has MDB
pains, too…

Rgds
Lutz

On Wednesday, 22 April 2015 20:14:09 UTC+2, Mehdi B wrote:

Check in folder:

lucee\tomcat\bin

you will find a tool "Luceew.exe" it will allow you to change JVM
used by tomcat. That would do the trick easily or allow you to
upgrade JDK, or even use the same as Coldfusion if you have them on
the same box like I did ;-).

More over JRE change here:
http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat
<http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat>

M B


On Wednesday, April 15, 2015 at 6:27:21 PM UTC+2, Chris wrote:

    My box is a Windows 2012 R2 (64bit) and I installed Lucee with
    the Windows installer from the downloads section on lucee.org
    <http://lucee.org>.  How can I change Lucee to use a 32bit java
    instead of 64bit?

    Thanks,
    Chris


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get
your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google
Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to lucee+unsubscribe@googlegroups.com
mailto:lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com
mailto:lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/762b9ef4-93a0-4c64-a856-f3c5f916806c%40googlegroups.com
https://groups.google.com/d/msgid/lucee/762b9ef4-93a0-4c64-a856-f3c5f916806c%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout.


See Lucee at CFCamp Oct 22 & 23 2015 @ Munich Airport, Germany - Get your ticket NOW - http://www.cfcamp.org/

You received this message because you are subscribed to the Google Groups “Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/lucee/55E5FADD.7050600%40viviotech.net.
For more options, visit https://groups.google.com/d/optout.

“I’m happy to report that I managed to use the UCanaccess project driver (
http://sourceforge.net/projects/ucanaccess/) with Lucee”

Do you have a quick tutorial on how you managed it please ?
Or maybe a link. Thanks.Le mardi 1 septembre 2015 15:09:34 UTC-4, lu...@lesener.de a écrit :

Dear all,

I have to support a legacy application that imports data from Access
databases. Today I had to move the application to a server running Windows
2012 R2 and ran of course into the JDBC issue mentioned here.

I’m happy to report that I managed to use the UCanaccess project driver (
http://sourceforge.net/projects/ucanaccess/) with Lucee. Requires no ODBC
object and connects nicely to the MDB files.

Having to support MDBs is actually the only reason why the server in
question is running Windows, so I’ll see if UCanaccess is also usable with
*nix boxes. Thought I’d share this in case somebody else has MDB pains,
too…

Rgds
Lutz

On Wednesday, 22 April 2015 20:14:09 UTC+2, Mehdi B wrote:

Check in folder:

lucee\tomcat\bin

you will find a tool “Luceew.exe” it will allow you to change JVM used by
tomcat. That would do the trick easily or allow you to upgrade JDK, or even
use the same as Coldfusion if you have them on the same box like I did ;-).

More over JRE change here:
http://www.codejava.net/servers/tomcat/4-ways-to-change-jre-for-tomcat

M B

On Wednesday, April 15, 2015 at 6:27:21 PM UTC+2, Chris wrote:

My box is a Windows 2012 R2 (64bit) and I installed Lucee with the
Windows installer from the downloads section on lucee.org. How can I
change Lucee to use a 32bit java instead of 64bit?

Thanks,
Chris

Oh nice thanks a lot. That works well with a standard mdb.
But did you also managed to make it work with a secured MDB + MDW database ?
I read a lot on jacksess/jackcessencrypt and can’t find a way to do it with
connection strings.
Maybe you have an idea ?

Merci beaucoup !Le jeudi 10 décembre 2015 05:02:01 UTC-5, lu...@lesener.de a écrit :

On Thursday, 10 December 2015 05:51:28 UTC+1, Kim Bélanger wrote:

Do you have a quick tutorial on how you managed it please ?
Or maybe a link. Thanks.

  1. Copy the JARs from the archive at
    http://sourceforge.net/projects/ucanaccess/files/ to the /lib folder of
    your Lucee installation. You will need at least ucanaccess-x.x.x.jar,
    jackcess-x.x.x.jar, and hsqldb.jar. Commons-lang-x.x.jar and
    commons-logging-x.x.x.jar are also required, but they might already be in
    /lib, I’d make sure I keep the latest version.

  2. Restart Lucee.

  3. Create a new datasource (either in code or in Lucee Admin) with these
    settings:
    this.datasources[“mdb”] = {
    class: ‘net.ucanaccess.jdbc.UcanaccessDriver’
    , connectionString: ‘jdbc:ucanaccess://d:/datapool/example.mdb’

// optional settings
, connectionTimeout: // default: 1; unit: seconds
};

The location of the MDB file in the example connection string refers to a
Windows machine. If you’re on Linux or OS X, it will look like this:
connectionString: ‘jdbc:ucanaccess:///Users/lutz/datapool/example.mdb’

HTH,
Lutz

Do you have a quick tutorial on how you managed it please ?
Or maybe a link. Thanks.

  1. Copy the JARs from the archive at
    http://sourceforge.net/projects/ucanaccess/files/ to the /lib folder of
    your Lucee installation. You will need at least ucanaccess-x.x.x.jar,
    jackcess-x.x.x.jar, and hsqldb.jar. Commons-lang-x.x.jar and
    commons-logging-x.x.x.jar are also required, but they might already be in
    /lib, I’d make sure I keep the latest version.

  2. Restart Lucee.

  3. Create a new datasource (either in code or in Lucee Admin) with these
    settings:
    this.datasources[“mdb”] = {
    class: ‘net.ucanaccess.jdbc.UcanaccessDriver’
    , connectionString: ‘jdbc:ucanaccess://d:/datapool/example.mdb’

// optional settings
, connectionTimeout: // default: 1; unit: seconds
};

The location of the MDB file in the example connection string refers to a
Windows machine. If you’re on Linux or OS X, it will look like this:
connectionString: ‘jdbc:ucanaccess:///Users/lutz/datapool/example.mdb’

HTH,
LutzOn Thursday, 10 December 2015 05:51:28 UTC+1, Kim Bélanger wrote:

Thanks, i posted this to this
end: https://sourceforge.net/p/ucanaccess/discussion/help/thread/b202c71e/Le jeudi 10 décembre 2015 15:00:19 UTC-5, lu...@lesener.de a écrit :

Hi Kim,

glad you got it working.
I haven’t tried it with encrypted MDBs, sorry. I’d recommend you try the
forum of the UCanAccess project (
https://sourceforge.net/p/ucanaccess/discussion/).

– Lutz

On Thursday, 10 December 2015 20:33:42 UTC+1, Kim Bélanger wrote:

Oh nice thanks a lot. That works well with a standard mdb.
But did you also managed to make it work with a secured MDB + MDW
database ?
I read a lot on jacksess/jackcessencrypt and can’t find a way to do it
with connection strings.
Maybe you have an idea ?

Merci beaucoup !

Hi Kim,

glad you got it working.
I haven’t tried it with encrypted MDBs, sorry. I’d recommend you try the
forum of the UCanAccess project
(https://sourceforge.net/p/ucanaccess/discussion/).

– LutzOn Thursday, 10 December 2015 20:33:42 UTC+1, Kim Bélanger wrote:

Oh nice thanks a lot. That works well with a standard mdb.
But did you also managed to make it work with a secured MDB + MDW database
?
I read a lot on jacksess/jackcessencrypt and can’t find a way to do it
with connection strings.
Maybe you have an idea ?

Merci beaucoup !