Cfthread still runs after ./shutdown.sh


#1

So this puzzles me. I have a cfthread that I kick off. it reads some data writes to a file.

I run ./shutdown.sh

But the thread is still running?

Explain that?


#2

Is localhost:8888 showing anything before you run shutdown?

It doesn’t look like your shutdown.sh complete successfully.

Is tomcat still running after?

ps -ef | grep tomcat

#3

Ill have to investigate that. I just thaught it was odd so i posted it.

I ended up, at least for now, looking up the running threads using cfm and using a .stop on the thread. I guess in java thats not recommended but it worked.


#4

Two suggestions. The first is that perhaps the JVM is in fact not running, but whatever you’re using to tail your console or log output is just lagging behind on updating. The second is that perhaps the JVM is just taking a while to shutdown. I’ve seen servers kept alive for up to 20-30 seconds after the server has stopped responding to web requests due to a hanging JVM shutdown hook that was keeping it running for a bit.

Start by confirming if the java process is still running. If it is, grab a thread dump with jstack -l PID to see what it’s doing. You may just need to be more patient.