Cfinvoke, error trying to access component address

I am trying to run an adobe coldfusion project on lucee. I installed Lucee and now I’m trying to page up.

I put the project folder at the following address C:\Lucee\tomcat\webapps, the index is in the following location C:\Lucee\tomcat\webapps\fase1\intuitivefase1 and the component in that location C:\Lucee\tomcat\webapps\fase1\intuitivefase1\componentes.

This is a legacy system and has no object oriented structure. All access is made by the cfinvoke tag, such as this:

<cfinvoke component="#cfcPath#.usuarioLogin"
method=“usuarioAutenticar2”

Where cfpath is the component path, located in application.cfm

I have already set up the datasource and it is connected to the database, but the problem happens before entering the component, so I believe that is not the problem.

When running the site the following error happens

invalid component definition, can’t find component [fase1.intuitivefase1.componentes.usuarioLogin]

The Error Occurred in
C:\Lucee\tomcat\webapps\fase1\intuitivefase1\login\loginEntrar.cfm: line 3

1:
2: <cfinvoke component="#cfcPath#.usuarioLogin"
3: method=“usuarioAutenticar2”**
4: >

lucee.runtime.exp.ExpressionException: invalid component definition, can’t find component [fase1.intuitivefase1.componentes.usuarioLogin]
at lucee.runtime.component.ComponentLoader._search(ComponentLoader.java:125)
at lucee.runtime.component.ComponentLoader.searchComponent(ComponentLoader.java:79)
at lucee.runtime.PageContextImpl.loadComponent(PageContextImpl.java:3150)
at lucee.runtime.tag.Invoke.doComponent(Invoke.java:206)
at lucee.runtime.tag.Invoke.doEndTag(Invoke.java:186)
at intuitivefase1.login.loginentrar_cfm$cf.call(/intuitivefase1/login/loginEntrar.cfm:3)
at lucee.runtime.PageContextImpl._doInclude(PageContextImpl.java:942)
at lucee.runtime.PageContextImpl._doInclude(PageContextImpl.java:834)
at lucee.runtime.listener.ClassicAppListener._onRequest(ClassicAppListener.java:64)
at lucee.runtime.listener.ClassicAppListener.onRequest(ClassicAppListener.java:47)
at lucee.runtime.PageContextImpl.execute(PageContextImpl.java:2409)
at lucee.runtime.PageContextImpl._execute(PageContextImpl.java:2399)
at lucee.runtime.PageContextImpl.executeCFML(PageContextImpl.java:2374)
at lucee.runtime.engine.Request.exe(Request.java:43)
at lucee.runtime.engine.CFMLEngineImpl._service(CFMLEngineImpl.java:1109)
at lucee.runtime.engine.CFMLEngineImpl.serviceCFML(CFMLEngineImpl.java:1055)
at lucee.loader.engine.CFMLEngineWrapper.serviceCFML(CFMLEngineWrapper.java:97)
at lucee.loader.servlet.CFMLServlet.service(CFMLServlet.java:51)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:741)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:231)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166)
at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:53)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:193)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:166)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:202)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:96)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:526)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:139)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:92)
at mod_cfml.core.invoke(core.java:180)
at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:678)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:74)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:343)
at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:408)
at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:860)
at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1587)
at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
at java.base/java.lang.Thread.run(Unknown Source)

I don’t know what to do, it works normally with adobe coldfusion

@leandrotto, Where is your Application.cfm located?

C:\Lucee\tomcat\webapps\fase1\intuitivefase1

@leandrotto use cfcpath=“componentes” or “C:.Lucee.tomcat.webapps.fase1.intuitivefase1.componentes” in your Application.cfm. Hope, now you can access the component file.

I tried and it did not work, I will do the following, install lucee again and count here if solved.

So … I did the following steps!

  1. I downloaded lucee lucee-5.3.3.062-pl0-windows-installer

  2. I created the system variable catalina_home and set the value C:\lucee\tomcat, set the path variable and set java_home to the openJDK address C:\Program Files\openJDK\jdk-13.0.1

  3. I tested the CMD installation of openJDK and everything went as expected.

  4. On Windows Server I released ports 8888, 8005, and 8009

  5. I then install lucee lucee-5.3.3.062-pl0-windows-installer

  6. I open the lucee welcome screen, where I also have access to the server / web settings, the service is running.

  7. I take the folder with my cfm pages from my coldfusion server, the full project and paste it to C: \ lucee \ tomcat \ webapps

  8. I access in the browser with the address http://127.0.0.1:8888/fase1/intuitivefase1 is forwarded to the address where index.cfm points http://127.0.0.1:8888/fase1/intuitivefase1/login/loginEnter.cfm

  • The same error already described happens.

  • I did not even configure the datasource, because the error does not let the data layer arrive.

Delete the web-inf directory for your application root
restart lucee

1 Like

I just did what you asked for and it didn’t work either. I did it that way, maybe I did something wrong.

  1. I stopped the tomcat lucee service

  2. I deleted the following web-inf folders

  • C:\lucee\tomcat\ webapps\fase1\WEB-INF

  • C:\lucee\tomcat\webapps\ROOT\WEB-INF

  1. I started the tomcat lucee service

I tried the cfpath variable with the following values

  • cfcPath = “componentes”
  • cfcPath = “C:.lucee.tomcat.webapps.fase1.intuitivefase1.componentes”
  • cfcPath = “fase1.intuitivefase1.componentes”

All gave the following error:

  • “invalid component definition, can’t find component”

The wanted component is C:\lucee\tomcat\webapps\fase1\intuitivefase1\componentes\usuarioLogin.cfc, file exists in place.

@leandrotto, Please put your project folder inside webapps/root directory. Then only we can access.

1 Like

What good news! It worked!

I did the following:

  1. I put the project in root
  2. I stopped the tomcat lucee service
  3. I deleted web-inf
  4. I put the value in the cfpath variable that already exists in adobe coldfusion which is fase1.intuitivefase1.components
  5. I started the tomcat lucee service
  6. I accessed the page http://localhost:8888/fase1/intuitivefase1/

I think it’s visible that I’m starting at Lucee, thanks for the support!

Now, I will keep trying to migrate the project to lucee.

Thank you!

1 Like

OK, Thankyou :slightly_smiling_face: @leandrotto