CF / Lucee incompatibility for createObject() / SOAP request

I could set-up a public accessible URL + login/password to this web service if somebody is willing to investigate it a little further. But for obvious reasons, I don’t want to put those details here.
I really want to migrate our application to Lucee, but unfortunately, I encounter several incompatibilities with CF 9.01, and as long I can’t fix them, I’m forced to migrate it to CF 2018 in the near future, which is not my preference.

Glad to look at it.

My go-to solution years ago was using the WSDL2Java.jar that was with cold fusion that creates a java version of the api and you can call all of that but it’s ugly as hell. PM me some details and I can see if I can get you a workaround.

Thanks Mark.
Mark found out it works perfectly on his setup (5.2.9.31).
I tried it on an express version of 5.2.9.31, and indeed, works as it should be.
So, probably something broke between 5.2.9.31 and 5.3.3.62. Will try with some express versions in between to see where exactly.

It looks like it broke between 5.2.9.31 and 5.3.1.95. Tried with all subsequent versions, none of them works. Tried with that latest snapshot (5.3.5.42), but same problem.

If somebody is willing to investigate this a bit further, or even fix it in code, here is a test code which can be used by everyone. The problem with this webservice is the same as on our private server:

<cfscript>
	ws = createObject ("webservice", "https://www.xtm-cloud.com/project-manager-gui/services/v2/XTMCustomerMTOMWebService?wsdl", {wsversion=1, refreshWSDL=true});
	XTM_getXTMInfo = ws.getXTMInfo({password="test", userId=1, client="test.com"},{});

	XTM_getXTMInfo_xtmInfo_logo = XTM_getXTMInfo.xtmInfo.logo;
	XTM_getXTMInfo_xtmInfo_version = XTM_getXTMInfo.xtmInfo.version;
	XTM_getXTMInfo_xtmInfo_companyname = XTM_getXTMInfo.xtmInfo.companyname;
	XTM_getXTMInfo_xtmInfo_website = XTM_getXTMInfo.xtmInfo.website;
</cfscript>

<cfoutput>
	#XTM_getXTMInfo_xtmInfo_logo#
	<br>
	#XTM_getXTMInfo_xtmInfo_version#
	<br>
	#XTM_getXTMInfo_xtmInfo_companyname#
	<br>
	#XTM_getXTMInfo_xtmInfo_website#
	<br>
</cfoutput>

When you run this on Lucee 5.2.9.31, you should receive this output/error, which is expected because the credentials are not good, but the function call is accepted:


However, when tested on 5.3.3.62, you get this error, which is not as expected:

Bugreport: https://luceeserver.atlassian.net/browse/LDEV-2597

Thanks!

nice comprehensive bug report :slight_smile: