Can't consume web service

Hello to all.

I am running Lucee 4.5.1.000 final with Java 1.8.0_45 x64 and am getting
this error when trying to consume a web service:
Message: Connection reset
Cause: java.net.SocketException

The code:
ws =
createObject(“webservice”,“https://www.somedomain.com:443/SomeService.asmx?WSDL”);
myReturn = ws.getReturn(myUserName=“somethinghere”,
myPassword=“somethingelse”, dataOne=“somedata”, dataTwo=“someotherdata”);

The same code that generates the error above on Lucee 4.5.1 with
Java 1.8.0_45 x64 runs fine on Railo 4.2.1.007 with Java 1.7.0_51 x64,
though I suspect this is not about Railo or Lucee, but about the version of
Java.

Any suggestions? I don’t want to go back to Java 7, of course.

All help appreciated.

-RR

the latest bleeding edge patch may fix this
https://luceeserver.atlassian.net/browse/LDEV-292On 4 June 2015 at 11:15, <@rrhodescf> wrote:

Hello to all.

I am running Lucee 4.5.1.000 final with Java 1.8.0_45 x64 and am getting
this error when trying to consume a web service:
Message: Connection reset
Cause: java.net.SocketException

The code:
ws = createObject(“webservice”,"
https://www.somedomain.com:443/SomeService.asmx?WSDL");
myReturn = ws.getReturn(myUserName=“somethinghere”,
myPassword=“somethingelse”, dataOne=“somedata”, dataTwo=“someotherdata”);

The same code that generates the error above on Lucee 4.5.1 with
Java 1.8.0_45 x64 runs fine on Railo 4.2.1.007 with Java 1.7.0_51 x64,
though I suspect this is not about Railo or Lucee, but about the version of
Java.

Any suggestions? I don’t want to go back to Java 7, of course.

All help appreciated.

-RR


You received this message because you are subscribed to the Google Groups
“Lucee” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to lucee+unsubscribe@googlegroups.com.
To post to this group, send email to lucee@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/lucee/daf4a07e-416f-480a-a2fc-436b3ed6986e%40googlegroups.com
https://groups.google.com/d/msgid/lucee/daf4a07e-416f-480a-a2fc-436b3ed6986e%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

AJ Mercer
<webonix:net strength=“Industrial” /> http://webonix.net | <webonix:org
community=“Open” /> http://webonix.org
http://twitter.com/webonix

Perhaps, but the server I am connecting to is not sharing ips. It’s one
web service and one IP. There is nothing else running on that server.

Thanks but I checked those already. No luck there.

But I did roll back to Java 1.7.0_60 and it works fine. I then rolled
forward, back to 1.8.0_45 and I got the same error again:
Message: Connection reset
Cause: java.net.SocketException

So createObject(“webservice” seems to work with Java 1.7.0_60 but not
1.8.0_45.

In both cases, I was running Lucee 4.5.1.

-RROn Thursday, June 4, 2015 at 11:25:09 AM UTC-4, Terry Whitney wrote:

Disable the firewall, check network connectivity.

usually these are caused by basic networking issues.

Disable the firewall, check network connectivity.

usually these are caused by basic networking issues.

Network packet logs e.g. from Wireshark are going to be handy here, if you
can ?

TomOn Thursday, June 4, 2015 at 10:07:57 PM UTC+1, rrho...@gmail.com wrote:

Thanks but I checked those already. No luck there.

But I did roll back to Java 1.7.0_60 and it works fine. I then rolled
forward, back to 1.8.0_45 and I got the same error again:
Message: Connection reset
Cause: java.net.SocketException

So createObject(“webservice” seems to work with Java 1.7.0_60 but not
1.8.0_45.

In both cases, I was running Lucee 4.5.1.

-RR

On Thursday, June 4, 2015 at 11:25:09 AM UTC-4, Terry Whitney wrote:

Disable the firewall, check network connectivity.

usually these are caused by basic networking issues.

Tom, thanks for that suggestion. I installed wireshark and tried the web
service again and I got two bright red lines that look like this (ip
addresses changed for security reasons):

24 0.151781000 111.222.333.444 192.10.1.2 TCP 60
4433→50038 [RST, ACK] Seq=5605 Ack=1503 Win=0 Len=0

I wonder if the problem is that we are using a non-standard ssl port?On Friday, June 5, 2015 at 11:24:49 AM UTC-4, Tom Chiverton wrote:

Network packet logs e.g. from Wireshark are going to be handy here, if you
can ?

Tom

On Thursday, June 4, 2015 at 10:07:57 PM UTC+1, rrho...@gmail.com wrote:

Thanks but I checked those already. No luck there.

But I did roll back to Java 1.7.0_60 and it works fine. I then rolled
forward, back to 1.8.0_45 and I got the same error again:
Message: Connection reset
Cause: java.net.SocketException

So createObject(“webservice” seems to work with Java 1.7.0_60 but not
1.8.0_45.

In both cases, I was running Lucee 4.5.1.

-RR

On Thursday, June 4, 2015 at 11:25:09 AM UTC-4, Terry Whitney wrote:

Disable the firewall, check network connectivity.

usually these are caused by basic networking issues.

My problem below was fixed with the latest Lucee update (4.5.2.000) and the
two replacement jars as shown here:

Thank you Team Lucee!On Wednesday, June 3, 2015 at 11:15:15 PM UTC-4, rrho...@gmail.com wrote:

Hello to all.

I am running Lucee 4.5.1.000 final with Java 1.8.0_45 x64 and am getting
this error when trying to consume a web service:
Message: Connection reset
Cause: java.net.SocketException

The code:
ws = createObject(“webservice”,"
https://www.somedomain.com:443/SomeService.asmx?WSDL");
myReturn = ws.getReturn(myUserName=“somethinghere”,
myPassword=“somethingelse”, dataOne=“somedata”, dataTwo=“someotherdata”);

The same code that generates the error above on Lucee 4.5.1 with
Java 1.8.0_45 x64 runs fine on Railo 4.2.1.007 with Java 1.7.0_51 x64,
though I suspect this is not about Railo or Lucee, but about the version of
Java.

Any suggestions? I don’t want to go back to Java 7, of course.

All help appreciated.

-RR