Build lucee 5 from source - JDK version

before I start, just want to make sure this doc is current
http://docs.lucee.org/guides/working-with-source/build-from-source.html

JDK version
conflicting messages:
Lucee requires JDK 6 or later in order to compile

vs

Java notes
Currently the build process requires Java 6 to build successfully, however
support for Java 7 and 8 will be added soon.–

AJ Mercer
<webonix:net strength=“Industrial” /> http://webonix.net | <webonix:org
community=“Open” /> http://webonix.org
http://twitter.com/webonix