Apache and .cfm mod_rewrite not working


#22

Its running on an Amazon EC2 linux image. I will check the permissions.

Thanks again


#23

are you using HTTPD 2.2 or 2.4? IIRC, Apache changed some syntax between these 2 versions, especially as related to <Directory> blocks. We had issues when upgrading from 2.2 to 2.4


#24

its 2.2.34


#25

Weird, as this is the configuration on my test vm, and it works as expected.

What is Lucee running as and its Apache running as the same user or group?

I ask as I have the same configuration on a CENTOS 7 box I use for development.

I use user and group apache for lucee
and I have SELINUX disabled.


#26

Yeah, I cant see why it is not working, I’m unable to get any rewriterules to work in the virtualhost.

Server is running apache under apache, lucee under root, starting to look like I might have to do a total rebuild of this server, I tried the lucee change user and it broke everything


#27

Okay so I removed mod_cfml and just used mod_proxy, all called from the .htaccess instead. that seems to have fixed i.

Thanks for all your help

Nick


#28

Glad to hear its working.


#29

Nick - would you be willing to post the final config setup that worked for you? I’m struggling with something similar (htaccess being sort of ignored and url rewriting not working) albeit I’m on Windows and running Apache 2.4. I’m looking for any model that might get URL rewriting working for me.