404 Not Found after installing Lucee


#1

I followed the instruction for installing Lucee on Mac OS X here: http://docs.lucee.org/guides/running-lucee/osx/installing-tomcat-and-lucee-on-os-x-using-the-lucee-war-file.html

Running 10.13.3 HighSiera and I have Apache 2.4.28 installed.

I installed TomCat 7 and could visit the main page on localhost:8080 without a problem.

After that I installed Lucee using the .war file stopping and starting the server.

My problem is when I visit: localhost:8080/lucee/admin/web.cfm I get a ‘404 Not Found’ message.

Has anyone else encountered this and been able to solve the problem?


#2

sigh, that page needs updating! Tomcat 7 is old, 8.5 is recommended

maybe you’re missing the ajp connector https://viviotech.github.io/mod_cfml/install-lin-ubuntu.html


#3

Thanks for your reply, I did update TomCat to 8.5 however there’s no clear documentation for the ajp connector on OS X. I can’t quite make out how to configure it from the Linux docs.


#4

the apache config is the pretty much the same across all platforms?

basically you need to enable a few apache modules
https://httpd.apache.org/docs/2.4/mod/mod_proxy_ajp.html

and then add the following to httpd.conf

<Proxy *>
Allow from 127.0.0.1
</Proxy>
ProxyPreserveHost On
ProxyPassMatch ^/(.+\.cf[cm])(/.*)?$ ajp://localhost:8009/$1$2

#5

Thanks for your detailed response.

I enabled mod_proxy and mod_proxy_ajp, added the code snippet you posted to the foot of the httpd.conf file, restarted apache.

Still have the same 404 Not Found message when I visit: localhost:8080/lucee/admin/web.cfm

Visiting localhost:8080/docs I can see TomCat docs.


#6

Since you are trying to install it on OSX, it looks like it’s your dev machine. Give Commandbox a try, it will spin up your server in seconds. https://www.ortussolutions.com/products/commandbox


#7

Thanks I got it running using CommandBox Docker container from the link you provided.